A4Tech mouse doesn't go smoothly on my macbook pro

Discussion in 'MacBook Pro' started by miw, Jul 18, 2010.

  1. miw macrumors newbie

    Joined:
    Jun 23, 2010
    #1
    Hi, I just bought the latest macbook pro. It is actually my first mac so I'm not really sure if this is supposed to happen. But I tried plugging in my "ordinary pc" (meant to say that is not a Mac mouse) mouse which is an A4Tech brand. It's working when I move the mouse in huge spaces. It goes smoothly that way. But when I try to move it in small little spaces, it's kind of like not going smoothly. Especially when I'm working on small details like Photoshop, it's kind of difficult to maneuver the mouse arrow. I tried other "pc" mouse as well but it's just the same.. Does this really happen if I'm not using Mac's mouse? How do I fix this?

    Thanks!
     
  2. Smultie macrumors newbie

    Joined:
    Jun 20, 2010
    Location:
    The Netherlands
  3. miw thread starter macrumors newbie

    Joined:
    Jun 23, 2010
    #3
    I guess that's what I'm currently using. A normal mouse that is not an :apple: brand.
     
  4. Smultie macrumors newbie

    Joined:
    Jun 20, 2010
    Location:
    The Netherlands
    #4

    Aah, I'm sorry; What I actually meant was "try buying a mouse that is not as crap as an A4tech." (Microsoft/Logitech for example)

    Although they offer a quite good value-for-money-ratio, they're too cheap to offer any real performance.
    Lack of Mac OS-drivers is one of things you'll miss on a brand like A4Tech/Trust/etc.
     
  5. miw thread starter macrumors newbie

    Joined:
    Jun 23, 2010
    #5
    Oh. Now I understand what you meant. I will try logitech on my Mac. Thanks! :)
     

Share This Page