AAAKKK!!! MacBook Pro Memory Upgrade problem...

Discussion in 'MacBook Pro' started by kk05629, Nov 28, 2007.

  1. kk05629 macrumors member

    Joined:
    Aug 8, 2007
    #1
    Greetings...I am trying to upgrade my MBP memory to 4gb. When I try to remove the 3 small screws in the battery compartment to expose the memory slots...the 3rd screw won't budge. I was using a Phillips 000 precision screw driver. The 1st 2 unscrewed fine. The 3rd does not budge. Now it appears stripped.

    Has any other members experienced this? Desperate for suggestions.

    Thanks in advance.
     
  2. Megatron macrumors regular

    Joined:
    Nov 19, 2005
    #2
    is there ANY part of the screwhead left or did you strip all of it?
     
  3. kk05629 thread starter macrumors member

    Joined:
    Aug 8, 2007
    #3
    Yes...The head is intact...but the edges of the + are rounded. I tried a 00 Phillips precision screw driver...but it is not getting any grip. I tried a flat head precision, but it is too cheap and the flat head bent.

    I suppose I could get a better quality flat head precision screwdriver and try that....

    I guess I could use a dremel tool to try to cut a flat slot into the head but honestly, I think I will screw it up. I wonder how an Apple Tech would resolve this? Drill out the screw?


    Again, advice welcome and appreciated.
     

Share This Page