General About ios 7 apps

Discussion in 'iOS 7' started by FatPuppy, May 10, 2014.

  1. FatPuppy macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
    #1
    Many apps now support ios 7 and some of them require only ios 7 but what about ios 6? How long can ios 6 live? App support is rapidly getting smaller and smaller and my iphone 4 is still on 6.1.3. How much time does ios 6 has?
     
  2. arefbe macrumors regular

    arefbe

    Joined:
    Sep 11, 2010
    #2
    Any guess I could make on that would be just as good as one you could make.
     
  3. CutterSlade macrumors regular

    CutterSlade

    Joined:
    Mar 13, 2014
    Location:
    Istanbul, Turkey
    #3
    As a developer, I think that not for long after 8 gets released. Supporting both 6.0 and 7.0 is a pain in the ass because there are too many differences that need to be handled.

    But in the end, it will ultimately depend on the number of users who will continue to use 6.0.
     
  4. dlewis23 macrumors 6502a

    Joined:
    Oct 23, 2007
    #4
    As a developer also I agree with this. Not long after iOS 8 apps that get updated likely won't support 6. For the apps I've started recently I have opted to not support iOS 6.
     
  5. Xenomorph macrumors 65816

    Xenomorph

    Joined:
    Aug 6, 2008
    Location:
    St. Louis
    #5
    You can still download apps for iOS 3, 4, and 5. iOS 6 will be safe for a while.

    As far as I know, it hasn't been that long since Apple required that app updates drop support for versions of iOS older than 4.3.
    Yes, the current Xcode 5, last updated in April 2014, will still let developers design and build iOS 4.3 apps.

    Now, if an individual app developer decides their new app needs iOS 7.1+ or iOS 8.0+, there is nothing you can do about it.
     
  6. Apple blogger macrumors 6502a

    Joined:
    Feb 28, 2013
    #6
    Well just because it supports ios 7 doesn't mean it'll stop for ios 6... Only new apps which are made will not have ios 6 support.. Most old apps require ios 5.x or more I think.. So yes , you have a year or 2 .. By that time I'm sure you will upgrade to a 5S or 6
     
  7. richwoodrocket macrumors 68020

    richwoodrocket

    Joined:
    Apr 7, 2014
    Location:
    Hamburg, NY
    #7
    If I was an app developer I would only support the latest version of iOS because I'm lazy.
     
  8. merrickdrfc macrumors 6502

    Joined:
    Jan 8, 2011
    Location:
    Manchester
    #8
    I support iOS 6 on apps that were built originally for 'classic' iOS, and also support iOS 7 with a separate updated UI. Any new apps however, iOS 7+ it's just not worth the sheer amount of work to create two separate UI's and actually make them good.
     

Share This Page