"About This Mac" button does'nt work...

Discussion in 'macOS' started by komatsu, Apr 19, 2018.

  1. komatsu macrumors 6502

    Joined:
    Sep 19, 2010
    #1
    In the last 10 days I've come across 3 different OS X systems from El Capitan to Sierra to High Sierra where the "About this Mac" button no longer functions.

    There is something seriously wrong with with OS X development process Apple if they cannot even get this rudimentary function right...
     
  2. casperes1996 macrumors 68040

    casperes1996

    Joined:
    Jan 26, 2014
    Location:
    Horsens, Denmark
    #2
    Where did you come across those systems?

    About this Mac has always worked on all my OS X systems from OS X 10.4 to macOS High Sierra. And everything also works on my OS9 G3 for that matter.
     
  3. komatsu thread starter macrumors 6502

    Joined:
    Sep 19, 2010
    #3
    Two different Macs in unrelated businesses.

    And on a home Mac.

    I really despair for OS X...
     
  4. casperes1996 macrumors 68040

    casperes1996

    Joined:
    Jan 26, 2014
    Location:
    Horsens, Denmark
    #4

    Peculiar. Any chance the users had intentionally disabled it? Never had issues like that for quite some time with OS X/macOS
     
  5. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    Yes, I see that occasionally. It's, in my experience, the lazy response of one of the later macOS systems running from a spinning hard drive. I've not seen it on a flash storage boot or SSD system. A quick reboot fixes it (although I find it hard to call a reboot in High Sierra from a hard drive as "quick" :D )
     

Share This Page