Resolved About to blow my brains out... (iPhone 4, MS, Safe Mode loop)

Discussion in 'Jailbreaks and iOS Hacks' started by Krafty, Oct 25, 2012.

  1. Krafty, Oct 25, 2012
    Last edited: Oct 25, 2012

    Krafty macrumors 601

    Krafty

    Joined:
    Dec 31, 2007
    Location:
    La La Land
    #1
    So after spending two days settings up this thing on 5.0.1 from 4.1, I had accidentally moved the PerferencesBunble folder without noticing, so my Preferences wouldnt start.

    After fixing it, I opened Cydia and there was a MobileSubsturate update, after updating, I resprung and was kicked into safe mode. But, there as no pop-up saying "This was caused by blah blah blah...", it just kicks me into safe mode with no way out.

    I can't launch any programs outside of the stock ones.

    So, now I'm stuck. I spent all that time working on this thing for this to happen.
     
  2. jinx1000 macrumors member

    Joined:
    Jul 12, 2010
    #2
    Have you tried holding the up key on the phone when rebooting?
    Then reinstall mobile substrate or remove recent apps?
    You can also use sbsettings to disable mobile substrate add-ons until you find the culprit if you can get into it.
    You could also remove mobile substrate and reinstall the apps. I've found that most cydia apps keep their settings on re-install.
     
  3. Krafty thread starter macrumors 601

    Krafty

    Joined:
    Dec 31, 2007
    Location:
    La La Land
    #3
    Yep. Same thing.

    Safe mode.
    Can't launch any jailbroken apps.
    No option to restart.
     
  4. jinx1000 macrumors member

    Joined:
    Jul 12, 2010
    #4
    I edited above but it sounds like it wouldn't help if you can't get into cydia...
     
  5. Krafty thread starter macrumors 601

    Krafty

    Joined:
    Dec 31, 2007
    Location:
    La La Land
    #5
    Yeah, can't launch Cydia or SBSettings. It doesn't even bother to load.
     
  6. jinx1000 macrumors member

    Joined:
    Jul 12, 2010
    #6
    You could always do a backup. Restore your phone. Restore backup. Jailbreak again. Again most of your jailbreak apps will retain settings after reinstalling.

    ----------

    Or maybe try to jailbreak again without restoring. Just some ideas.
     
  7. Krafty thread starter macrumors 601

    Krafty

    Joined:
    Dec 31, 2007
    Location:
    La La Land
  8. jinx1000 macrumors member

    Joined:
    Jul 12, 2010
    #8
    I'm surprised it goes into safe mode when holding the up key on reboot. That has always fixed it for me...

    ----------

    Not sure if you can. I was thinking run absinthe again. Actually redsn0w for iPhone 4 I guess.

    Wonder if you're permissions somehow changed on the preference bundle.
     
  9. Krafty thread starter macrumors 601

    Krafty

    Joined:
    Dec 31, 2007
    Location:
    La La Land
    #9
    Wow. I thought MacRumors would be the last place I'd expect a solution cause on average I never get replies.

    But, yeah, all I did was run redsn0w, put it in DFU, and re-jailbroke and bam, back in business. And to think I fired up my moms PC to restore.

    Thank you so much. And to think this all happened because I was trying to find the damn twitter icon in the banner notifications.

    I'll have someone else attempt to find it, I am getting out of the root of my iPhone before I **** something else up.
     
  10. jinx1000 macrumors member

    Joined:
    Jul 12, 2010
  11. Krafty thread starter macrumors 601

    Krafty

    Joined:
    Dec 31, 2007
    Location:
    La La Land
    #11
    Thank you for your time.
     

Share This Page