• Did you order new AirTags? We've opened a dedicated AirTags forum.

spencecb

macrumors 65816
Original poster
Nov 20, 2003
1,037
72
I am SO FREAKING SICK of the abysmal WiFi performance of my MacBook Pro. It seems to be having two key problems.

First of all, when it wakes from sleep, it frequently disconnects from my WiFi. I notice this because of webpages not loading once woken from sleep, or messages not sending for up to a couple minutes while it decides if it is actually going to use my high speed WiFi or just sit there and do nothing.

Secondly, when it does work, I have horrendous speeds. I ran Speedtest and took screen shots of both my MacBook Pro and my iMac, sitting on the same desk. Its like my MacBook Pro has reverted back to using a 56k modem.

Everything is up to date, and I know it is not an issue with my WiFi access point (I use Ubiquiti which is amazing).

Any ideas on what I can do? First two attachments are the MacBook Pro, second are from my iMac (download followed by upload).
Screen Shot 2021-05-03 at 3.13.46 PM.png
Screen Shot 2021-05-03 at 3.14.04 PM.png
Screen Shot 2021-05-03 at 3.14.16 PM.png
Screen Shot 2021-05-03 at 3.14.25 PM.png
 

Audit13

macrumors 603
Apr 19, 2017
6,086
1,575
Toronto, Ontario, Canada
Which MacBook do you have? Wifi is connected at 5 Ghz?

iMac is wireless too?

I have a mid-2014 Pro 13" and get good speed on Wifi connected to an Asus RT-AC86U router located in the basement and MacBook on the 1st floor.
 

Attachments

  • Screen Shot 2021-05-03 at 3.29.08 PM.png
    Screen Shot 2021-05-03 at 3.29.08 PM.png
    135.4 KB · Views: 15
Comment

spencecb

macrumors 65816
Original poster
Nov 20, 2003
1,037
72
Hardware is:

MacBook Pro 2019 15"
iMac 27" 5k 2017

Now that you asked, I did look at the WiFi connection, and my iMac is connected at 5 GHz and my MacBook Pro is connected at 2.4 GHz...

Should I delete my network connection on the MacBook Pro and rejoin?
 

Attachments

  • Screen Shot 2021-05-03 at 3.32.07 PM.png
    Screen Shot 2021-05-03 at 3.32.07 PM.png
    69.9 KB · Views: 20
  • Screen Shot 2021-05-03 at 3.33.29 PM.png
    Screen Shot 2021-05-03 at 3.33.29 PM.png
    175.4 KB · Views: 21
Comment

spencecb

macrumors 65816
Original poster
Nov 20, 2003
1,037
72
I deleted the connection, added it, and it is now even worse than it was before...
 
Comment

Alpha Centauri

macrumors newbie
Oct 13, 2020
1
0
I'm not really sure what you are asking here. Both computers have 802.11ac capability.
Indeed I noticed that too. Looking at your screenshot, assuming the MBP is for the right picture, it's running the aged 802.11n standard. It should be as the iMac also on 802.11ac
 
Comment

RAMtheSSD

macrumors regular
This is absurd, a 2019 MBP that connects to a router that is primarily ac or ax should not be running in N mode. Since it is Fl, I would not risk even breathing the air outside but call Apple and be patient while waiting for the answer but insistent once you get someone. I do not mean be rude to some poor man or woman trying to keep his or her head above water but don't give in either. Your signature does not suggest poverty but that machine is still an investment in value for your money and quality of build. Right now, you are not getting either.

I would have said that your environment is filled with electrical interference or that your router is poorly located with respect to the place you normally use your MBP but the side by side test nixed that --different from what I talk about below, that can happen even when in a clear line of sight with the router but (AFAIK) only when destructive interference occurs-- With considerably slower service and far more electrical interference, I am getting better speed out of an n router most of the time and my machine is old enough that Apple thinks it wears bell bottoms and a peasant blouse. So, unless your router is as old as mine --and you'd have to work at that, I only bought a router because guests' laptops do not always have RJ-45 ports and phones get better service when connected to wifi-- there is something wrong with either the router or the machine and the router appears to be working very well indeed.

One thing to try: turn the wifi in everything else off and test the MBP. Maybe your router does not have MESH or MU-MIMO and maybe... I recall reading somewhere that it is possible to slow down a router and fall down into the single channel world by using two otherwise very capable devices far apart enough for people but too close for the router... It is worth testing but routers and range extenders are relatively inexpensive compared to the investment you made in your MBP, I would call Apple.
 
Comment

4sallypat

macrumors 68000
Sep 16, 2016
1,866
1,548
So Calif
How far away are you from the router ?
Has the router been updated (firmware) ?
Can your router run AX (Wifi 6) ?
 
Comment

spencecb

macrumors 65816
Original poster
Nov 20, 2003
1,037
72
We have a main WiFi access point that basically covers the entire house, as it is centrally located. We have a second one outside to cover the outdoor space/pool. Both are Ubiquiti access points. They are both 5 GHz, ac capable.

I might take the time to try and troubleshoot over the phone with Apple, as diagnosing WiFi problems when not on my own WiFi is problematic.

When I had problems in the past (on different computers) I remember being able to delete a .plist file, but I can't recall which one you are supposed to delete or its exact location. If anyone knows what I am talking about, advice would be appreciated!
 
Comment

j0nblayz

macrumors 6502
Jul 21, 2007
264
87
since your using ubiquiti, I would say create a new wireless SSID for testing and only have 5ghz enabled on the test SSID. Do Speedtest and see if that helps. My guess you have major interference on your 2.4ghz hence the low speed. Keep in mind device will try to connect to the strongest connection, meaning your 2.4ghz is prob stronger since it has greater distance.

Now using the test SSID if speed is good on 5ghz, we can determine that it’s an issue with the 2.4ghz. I would next do a network scan, netspot is a great freeware tool to scan the used channels. Read up on overlapping channels, highly recommend using 1,6 or 11 for 2.4ghz as there is no overlap.

determine which one is the best channel and enable 2.4ghz/disable 5ghz on your test ssid and do some Speedtest. If you find a good channel you want to use, switch over your production ssid to that channel and disable the test SSID.

lastly I don’t know how complex your network is, but if you have different vlans per ssid or any additional gateways, that could be the root issue too. Another issue could be UTM if you are using any advanced firewall with IPS or threat protection. Also doesn’t hurt to reboot your access point and your gateway router.
 
Comment

4sallypat

macrumors 68000
Sep 16, 2016
1,866
1,548
So Calif
...... Keep in mind device will try to connect to the strongest connection, meaning your 2.4ghz is prob stronger since it has greater distance.

Now using the test SSID if speed is good on 5ghz, we can determine that it’s an issue with the 2.4ghz. I would next do a network scan, netspot is a great freeware tool to scan the used channels. Read up on overlapping channels, highly recommend using 1,6 or 11 for 2.4ghz as there is no overlap.

determine which one is the best channel and enable 2.4ghz/disable 5ghz on your test ssid and do some Speedtest. If you find a good channel you want to use, switch over your production ssid to that channel and disable the test SSID.

lastly I don’t know how complex your network is, but if you have different vlans per ssid or any additional gateways, that could be the root issue too. Another issue could be UTM if you are using any advanced firewall with IPS or threat protection. Also doesn’t hurt to reboot your access point and your gateway router.
Great idea!

I disabled my 2.4Ghz WLAN radio on my router.
We only use 5GHz to prevent slower traffic on 2.4.

Also, I disabled 2.4Ghz to avoid interference with bluetooth devices...
 
  • Like
Reactions: spencecb
Comment

j0nblayz

macrumors 6502
Jul 21, 2007
264
87
Great point, yes Bluetooth since it uses 2.4ghz can interfere with the 2.4ghz wifi network. Some cases to the point where wifi is impacted greatly. Hence its great to use some type of wifi scanner to determine interference and pick the best channel, again 1,6,11 and recommend 20mhz wide to reduce overlap. For me, I have over 60 devices in my house, and some of the IoT devices only work on 2.4ghz so dont have the luxury of disabling, also with the added distance, sometimes its nice to get coverage outside.

Another thing to look at is coverage and # of AP's required. For me, I have 4 AP's in my house. One for each floor on opposite ends of the floor, and 2 upstairs as I have too many walls impacting coverage.

5ghz is a whole different story, much more flexibility but again still need to consider overlap. A lot of great articles out there to determine overlapping channels.

As you guys probably guessed, I am a huge network geek. I can go on for hours with best practices, but general rule of thumb, dont use overlapping channels, it doesn't just impact you, it impacts all your neighbours with overlapping channels. Also Tx power is something to consider, not so much on single AP, but when you have multiple you will need to scan and determine proper Tx power to have proper fast roaming (especially with 802.11k/v protocols)
 
Comment

spencecb

macrumors 65816
Original poster
Nov 20, 2003
1,037
72
Great point, yes Bluetooth since it uses 2.4ghz can interfere with the 2.4ghz wifi network. Some cases to the point where wifi is impacted greatly. Hence its great to use some type of wifi scanner to determine interference and pick the best channel, again 1,6,11 and recommend 20mhz wide to reduce overlap. For me, I have over 60 devices in my house, and some of the IoT devices only work on 2.4ghz so dont have the luxury of disabling, also with the added distance, sometimes its nice to get coverage outside.

Another thing to look at is coverage and # of AP's required. For me, I have 4 AP's in my house. One for each floor on opposite ends of the floor, and 2 upstairs as I have too many walls impacting coverage.

5ghz is a whole different story, much more flexibility but again still need to consider overlap. A lot of great articles out there to determine overlapping channels.

As you guys probably guessed, I am a huge network geek. I can go on for hours with best practices, but general rule of thumb, dont use overlapping channels, it doesn't just impact you, it impacts all your neighbours with overlapping channels. Also Tx power is something to consider, not so much on single AP, but when you have multiple you will need to scan and determine proper Tx power to have proper fast roaming (especially with 802.11k/v protocols)
I ended up restarting my switch and both WiFi access points, and that did the trick to get the MacBook Pro back on the 5 Ghz network. I do still need my 2.4 GHz network, because like you, I have a few IoT devices that are only using that spectrum. I'd prefer to just disable it, but that won't be the case for the time being.

Btw, a lot of what you said was over my head. I used to know a lot more about this, especially when I worked for Apple in the early-to-mid 2000's. But a lot has changed since then.

I do have to say that I am very pleased with Ubiquiti's products. They are very reliable.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.