Accelerometer not working in photos on iPhone 4????

Discussion in 'iPhone' started by doctordowling, Jun 26, 2010.

  1. doctordowling macrumors member

    Joined:
    Jun 23, 2010
    #1
    Does anyone else have a problem where their photos app will not utilize the accelerometer; I thought this was a function of iOS 4?

    I can't rotate the galleries and even when playing a video that I recorded on the phone, It won't rotate to landscape.
     
  2. thrust macrumors member

    Joined:
    Jul 22, 2008
  3. JonB3Z macrumors 6502

    Joined:
    Jun 23, 2009
    #3
    Works for me. At the risk of stating the obvious, you don't have the portrait orientation lock on, do you?
     
  4. iPhone43 macrumors newbie

    Joined:
    Jun 18, 2010
    #4
    I think mine worked when I got it...


    Now it doesn't though. Not sure why, the lock is definitely off and has been switched on and off multiple times. I don't want to reset or restore since it's not a life threatening problem. Definitely want this fixed in the next firmware or beforehand with a work around. Keep me updated!
     
  5. Bosley69 macrumors newbie

    Joined:
    Jul 15, 2010
    #5
    iPhone 4 photos wont rotate

    Hi,
    I had this problem and I was pulling my hair out.. However I finally figured out the answer!

    The problem seems to occur when too many programs (or problematic specific one(s)) are running. The cure was to double tap the Home button to bring up the multi-tasking bit.
    Then hold your finger on an application to make them wobble and bring up the delete symbol.
    Next delete all the programs that are currently shown there - ie are currently multi-tasking.
    Your rotation should now be back working.
    I guess you could work out which program(s) cause the problem, but I haven't been that sytematic yet!!
    (incidentally - I had to do this after closing Co-Pilot too so that it turned off the GPS and stop my battery draining!)

    Hope this helps
     
  6. iPhone43 macrumors newbie

    Joined:
    Jun 18, 2010
    #6
    I tried that and it didn't work. However... I reset network settings which somehow fixed it.
     
  7. luckylewis7 macrumors newbie

    Joined:
    Sep 8, 2010
    #7
    Accelerometer Problem

    Dear iPhone 4 users,

    I experienced this problem too, my photos wouldn't rotate 90 degrees after taking a photo landscape: Turn your phone off and turn it back on and everything works as it should! Hope this helps!

    Lewis
     
  8. phillipsteak macrumors member

    Joined:
    Mar 28, 2008
    #8
    Yeah happened to me. A reboot should fix the problem
     

Share This Page