"Accept Incoming Network Connections"? Popup - How can I stop it?

Discussion in 'macOS' started by bully worm, Jul 13, 2010.

  1. bully worm macrumors regular

    Joined:
    Sep 17, 2009
    #1
    Everytime I open up Office Word or Itunes, this popup repeatedly shows up even though I accept "Allow" every single time.

    I have gone into System pref->Firewall and see that it is set on "Allow Incoming Connections".

    I've tried deleting it from the list and re-adding it again but it still shows up.

    I'm running 10.6.4 on a late 09 UMBP with the latest version of Word and Itunes.

    Anyone got a fix for this nuisance?
     
  2. MacKeeperFanMod macrumors regular

    MacKeeperFanMod

    Joined:
    Jun 28, 2010
    #2
    It's probably easiest to reinstall iTunes.

    If the firewall does not remember your choice, then the digital signature (Code Signing) of iTunes is broken. By default, the OS X firewall accepts any software that was signed by Apple without even asking you. So: it should not have asked you. And once asked, it should be able to remember, based on the digital signature. A broken signature (for example caused by changing the contents of the iTunes.app package) will prevent all this.

    (Did you by any chance manually change the iTunes icon the application somehow? Or did you install some plugins?)

    You can validate the signature of your iTunes by copying the first line and paste it in Terminal:

    Code:
    codesign -vvv /Applications/iTunes.app/
    
    /Applications/iTunes.app/: valid on disk
    /Applications/iTunes.app/: satisfies its Designated Requirement
     
  3. bully worm thread starter macrumors regular

    Joined:
    Sep 17, 2009
    #3
    Okay iTunes seems like it is working just fine now without the annoying popup.

    But Microsoft Word is still showing it. Do you also have a fix for that?

    Thank you for your help by the way kind sir.
     
  4. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #4
    Reinstall Office.
     
  5. MacKeeperFanMod macrumors regular

    MacKeeperFanMod

    Joined:
    Jun 28, 2010
    #5
    Try the same for Microsoft Office.

    Code:
    codesign-vvv / Applications / iTunes.app /
    Instead of "/ Applications / iTunes.app /" put the address to the application that opens when you start Office Word.

    But I have never worked with Microsoft Office, so only guess.

    Or really reinstall Office.
     
  6. bully worm thread starter macrumors regular

    Joined:
    Sep 17, 2009
    #6
    Yeah it didn't work with Word. Thanks for the help though.
     
  7. occamsrazor macrumors 6502

    occamsrazor

    Joined:
    Feb 25, 2007
    #7
    I have the same problem with a whole bunch of apps, it's bloody annoying...
     
  8. sturla75 macrumors newbie

    Joined:
    Aug 16, 2010
    Location:
    Oslo, Norway
    #8
    Me too! With a bunch of applications. I can't seem to find a solution. Hope someone can help.
     
  9. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #9
    Try reinstalling the apps first. If that doesn't work, try removing com.apple.alf.plist from /Library/Preferences.
     
  10. thanachai macrumors member

    Joined:
    Dec 2, 2008
    #10
    Thank you^99
     
  11. Gdubyew macrumors newbie

    Joined:
    Jan 4, 2015
    #11
    Popup Stop

    I got the same annoying messages in both Word & Excel 2008 (Mac). Here are the steps I took:

    1) I used the "CleanMyMac 2" utility to locate and delete all the prefs associated with Word/Excel/Office
    2) deleted com.apple.alf.plist from /Library/Preferences
    3) RESTARTED my Mac (like many of us, we rarely do an actual restart).

    That fixed it for me. Life is back to good now.
     

Share This Page