Access broken computer via screen sharing

Discussion in 'macOS' started by cfhjag, Apr 2, 2013.

  1. cfhjag macrumors member

    Joined:
    Jun 19, 2012
    #1
    Hello all,

    I got a problem with my old Macbook Pro. The computer starts up just fine and I can get it to join the network by plugging in a cable, but the screen is pitch black. I've tried to connect an external screen, resetting ram, starting in safe mode etc etc but nothing works, screen stays black.

    It's not really a big issue though since I'll use the computer as a media center but I thought, if I can access it through screen sharing, it'll work. Problem is that I don't know how I can activate it with a blank screen. I can get to system preferences, searching for sharing, one press down takes me there, tab 2 times and I'm in the menu BUT I can't check the box.

    So, does anyone know how I can check a box in system preferences only using the keyboard?
     
  2. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #2
    Do you have another Mac? Target Disk Mode would work if so. You're going to have to run to the store to get a wire though.
     
  3. cfhjag thread starter macrumors member

    Joined:
    Jun 19, 2012
    #3
    You mean to start the computer as a HD using a firewire? Issue isn't the files etc on the computer, just the screen. Everything works just fine except for the screen. It would be perfect if I could, under sharing in finder, access it through share screen but I only see the files there.
     
  4. Jessica Lares, Apr 2, 2013
    Last edited: Apr 2, 2013

    Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #4
    Yeah. But at least you could turn the sharing on. Or even put a shortcut to the app on the desktop or turn on VoiceOver to help you. You know, actually boot the drive on the other Mac, add the shortcut/voiceover, turn it off, disconnect, and reboot. Have you ever done that? ;)
     
  5. cfhjag thread starter macrumors member

    Joined:
    Jun 19, 2012
    #5
    VoiceOver is a very interesting option. So booting on another mac? Simply by firewire, and then holding down option on startup?
     
  6. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #6
    Yeah, as long as the Mac can run that same OS it should work.
     
  7. justperry, Apr 2, 2013
    Last edited: Apr 2, 2013

    justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #7
    I have it partly covered by doing the following.

    1. Hold Command-Shift-G, then enter /Applications/System Preferences

    2. Hit Enter, wait 30 seconds or so for it to open.

    3. Type "Sharing" without quotes, hit enter, wait 10 seconds or so for it to Open

    4. Hit the Tab button twice, now it gets tricky, where is the selection, in my case it was on Remote Management.

    5. Just hit the arrow up 10 times, the selecting now is set to the top one, after this hit the down arrow 5 times, this will get the selection to Remote management.

    6. Yours will have the checkbox unchecked, you need to activate it but how I am not sure yet.

    I will update if I find the answer to # 6

    If the Padlock is locked it will be even more difficult, see screenshot.

    Update: I am stuck after #6 , I did not find a keyboard shortcut to enable the checkbox, tried many different keys like with the Option, Shift, FN key but no go.
     

    Attached Files:

  8. cfhjag thread starter macrumors member

    Joined:
    Jun 19, 2012
    #8
    That's exactly where I got to too. Can't figure out how to check that stupid box!
     
  9. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #9
    Command-F5 will turn on VoiceOver. If you go to the Sharing options, just hit tab multiple times, and it'll get you to the lock. Just tried it myself.
     

Share This Page