Access files via USB or SSH using Windows Explorer without iTunes

Discussion in 'Jailbreaks and iOS Hacks' started by sch11, Jan 26, 2012.

  1. sch11 macrumors member

    Joined:
    Dec 21, 2010
    #1
    I haven't had much luck searching. What's the best way of accessing your iPhone file system using Windows explorer, if you don't have iTunes installed? I know you can use an SSH client like WinSCP to access files, but that's more cumbersome than mapping a network drive. And, of course, SSH access using WiFi is slower than USB.

    There seem to be some good options if you have iTunes installed, but I want to avoid doing that if at all possible. Thanks for any suggestions.
     
  2. BobboZR2 macrumors regular

    Joined:
    Jul 3, 2008
  3. sch11 thread starter macrumors member

    Joined:
    Dec 21, 2010
    #3
    Thanks for the suggestion. All of macroplant's applications seem to require iTunes to work on Windows.
     
  4. BobboZR2 macrumors regular

    Joined:
    Jul 3, 2008
    #4
    Ah, I see. I didn't realize there was an iTunes requirement for it. I guess it's because I've always had iTunes.

    Why are you shying away from iTunes?
     
  5. sch11 thread starter macrumors member

    Joined:
    Dec 21, 2010
    #5
    No good reason, really. I just don't want to install iTunes on all the computers I'd like to transfer files from. It's very intrusive (incessant update prompts, prompts to install unrelated software, random content deletion threats, constant phoning home, etc.).
     
  6. hidefguy macrumors 6502

    Joined:
    Oct 14, 2009
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    Simple, you need the device drivers installed on your computer to use USB iexplorer and other clients besides winscp.
    No itunes then no drivers installed.
    Your pick.
     
  8. sch11 thread starter macrumors member

    Joined:
    Dec 21, 2010
    #8
  9. AnionicStrength, Jan 26, 2012
    Last edited: Jan 27, 2012

    AnionicStrength macrumors member

    Joined:
    Dec 28, 2010
    #9
    I'm surprised no one has mentioned it yet, but the Samba package on the BigBoss repository is great for just this reason.

    Once you have it installed on your phone, and have set a root password, you can connect to a read/write share directory on your phone.

    This shared directory is located at /var/samba_share on the iPhone filesystem.

    Once your iPhone and the computer you want to access it from are on the same network, you can access it just like any other SMB share.

    On Mac:

    Finder > Go > Connect to Server... (⌘+K)
    Next type in smb://root@<iPhone IP address> and press Connect

    [​IMG]

    Obviously you need to replace <iPhone IP address> with the actual IP address of your phone.

    On Windows:

    Right click My Computer and select "Map Network Drive"
    Type \\<iPhone IP address>\share into the folder field and click finish.

    [​IMG]

    The speeds are pretty good, but kind of what you would expect out of the iPhone's Wifi chipset.

    Enjoy.
     
  10. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #10
    open ssh on your phone an ifunbox

    couldn't be simpeler
     
  11. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #11
    WinSCP couldnt be easier


    why fumble around with drivers that your not sure on?
     
  12. AnionicStrength macrumors member

    Joined:
    Dec 28, 2010
    #12
    I fail to understand how installing any program is easier than connecting by SMB which is installed on all major operating systems by default.

    I suppose to each their own though...
     
  13. sch11 thread starter macrumors member

    Joined:
    Dec 21, 2010
    #13
    Thanks a lot for pointing out that samba package. In practice, when you use that to transfer files to your iPhone, how do you transfer your files from the shared samba directory to the folder you want them in?
     
  14. sch11 thread starter macrumors member

    Joined:
    Dec 21, 2010
    #14
    For anyone interested, following the copytrans guide worked for me. I can now access my iPhone via USB using iFunBox without iTunes installed. But note the following:

    1. I used the method that involves downloading the iTunes setup file, renaming it to a zip file, and extracting AppleMobileDeviceSupport.msi, etc.

    2. I installed AppleMobileDeviceSupport.msi before AppleApplicationSupport.msi, and I ran into a Windows error relating to a problem starting the Apple Mobile Device service. There were two kinds of error messages - one was a Windows error reporting prompt, and another was an installer error warning that gave me the option to abort, ignore, or retry. I ignored the error; AMDS installed without further incident; and the AMD service started properly after I installed AAS.

    3. I didn't install Quicktime; I already had QT Alternative installed. I haven't run into any problems yet, but I've only transferred a few files so far.

    I'll post back if I run into problems. Please let me know if I've done something stupid.

    For people interested in the Samba option AnionicStrength mentioned, there's a shareware package on Cydia that allows you to do something similar. The free version only gives you access to a single folder (which doesn't seem very useful), but a paid version allows you to access the entire filesystem using a samba share. This sounds very nice, but I probably won't bother with it, since it's a huge package that not many people seem to be using, so I suspect it may not be very efficient or stable, etc.
     

Share This Page