Accessing App Store kills my DNS

Discussion in 'OS X Mountain Lion (10.8)' started by artemisworks, Oct 29, 2012.

  1. artemisworks macrumors newbie

    Joined:
    Oct 29, 2012
    Location:
    UK
    #1
    I have had a very maddening problem for the past few weeks and I wonder if anyone else has come across this.

    I am running a Mac Mini 2.3Gz machine with Mountain Lion OS X 10.8.2. I recently got this machine - just over a month ago and initially everything worked fine with it. However in the past month or so, I've been having horrendous problems accessing the Apple App Store.

    Here's what happens. Everything seems fine with my broadband internet connection, but when I start up the App store, it seems to load very, very slowly. Most of the time, the images don't load along with the text. After a while, it'll tell me that "an internet connection is required to access the app store". Then when I try to browse other websites, everything hangs. However, if I try to ping IP addresses (such as Google's DNS), it still pings normally, which means that DNS is somehow killed but my internet connection is still up.

    I have to kill the App store to get DNS working again. Sometimes it comes back again without intervention after 5-10 minutes. Or if I kill mDNSResponder manually and start it up again, it also seems to get DNS working again.

    I kill it thus:
    sudo launchctl unload /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

    then I start it up again:
    sudo launchctl load /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

    What is going on with accessing the App Store that seems to screw up mDNSResponder?? I've repeated this test many times over and confirmed that it happens every single time so it's no coincidence. I've tried flushing the DNS cache on my Mac to no avail.

    I'm not a networking expert so if anyone can help, please let me know what I can try next. Thanks if you've read this far!

    PS: this only started happening maybe 3-4 weeks ago.

    Artemisworks
     
  2. artemisworks thread starter macrumors newbie

    Joined:
    Oct 29, 2012
    Location:
    UK
    #2
    Unsurprisingly, I've not got a reply for this rather weird problem.

    Anyway it turned out to be my router + ADSL modem combination. They're getting old and upon repeated tests, I found I was able to kill my internet connection for ALL my devices and not just my Mac, just by kicking off the App Store in my Mac. This narrowed down the problem to my router, so I just replaced it with a backup and now the App Store works again. The connection is also a lot less flaky now.

    Thanks again for reading. Problem solved.
     
  3. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #3
    Glad you got your problem solved. :)
     

Share This Page