Accessing printer connected to Buffalo Linkstation

Discussion in 'macOS' started by argyleuk, Jun 29, 2010.

  1. argyleuk macrumors newbie

    Joined:
    Jun 29, 2010
    #1
    First post from me, a recent Macbook pro convert from windows and have found this forum invaluable as a new switcher. However, there is one problem I cannot resolve, I have an HP printer connected to my Buffalo Linkstation Live NAS which works fine on my windows computers but for the life of me I cannot get my Mac to see it. It has a static IP and i've tried putting this into the printer and fax utility with no joy, also connected it directly via usb and installed the correct software and it works fine, but as soon as I try and access it over my network, no joy.
    any suggestions greatfully received!!
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
  3. argyleuk thread starter macrumors newbie

    Joined:
    Jun 29, 2010
    #3
    Yeah I can ping and access the NAS no problem at all, i've set up the WINS section of the network setup and when i try and add a printer on the windows section it shows my network, then the NAS but nothing further, and yes the printer is on!!;)
     
  4. ohickmott macrumors newbie

    Joined:
    Jul 26, 2008
    #4
    Hi argyleuk,

    Did you ever get anywhere with this?

    Cheers
    Olly
     
  5. ohickmott macrumors newbie

    Joined:
    Jul 26, 2008
    #5
    Solution for OS X Printing to Linkstation

    Hi argyleuk,

    I assume that from my previous reply this conversation is considered 'dead' but for my own piece of mind and hopefully to aid others stumbling onto this link this is how to get an OS X workstation printing to a printer attached to a Buffalo linkstation :

    - open system preferences
    - select "print & scan"
    - click the plus icon to add a new printer
    - hold "ctrl" and click on "default" in the toolbar, then "customize toolbar"
    - add "advanced" to your toolbar
    - select type "LPD"
    - complete the url with your printers ip (e.g. lpd://your.nas.ip.here/lp)
    - select your printers driver
    - click add

    This worked for me on OS X Lion connection to a LS-WXL

    Hope this info is of use

    Kind Regards
    Olly
     
  6. street macrumors newbie

    Joined:
    Mar 1, 2012
    #6
    Hey ohickmott,
    just wanted to say thanks for your solution. moved to Lion, found work around for time machine but was struggling with the scx-4200. From your instructions now works fine. Thank-you!
     
  7. orlandomacrumors macrumors newbie

    Joined:
    Jun 6, 2015
    #7
    Thanks This worked for me After several trial and errors (a couple of hours) I found this page I signed up for this website just to thank and confirm It works Thanks
     
  8. orlandomacrumors macrumors newbie

    Joined:
    Jun 6, 2015
    #8
    Just to add 2008 Macbook Yosemite with a NIB Buffalo LS220DE NAS Latest drivers firmware etc from Buffalo website
     

Share This Page