"Accessory not supported by iPhone?"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by javiwankenobi, Apr 2, 2012.

  1. javiwankenobi macrumors member

    Feb 1, 2009
    So yesterday I had some trouble with my iPhone 4. The volume went away. I flipped mute and back and still didnt work until I plugged the headphones in and the problem went away.

    Right after that I realized that I wanted to plug in my iPhone on some philips dock speakers I use everyday and this message pops up saying "Accessory not supported by iPhone", except, I been using it everyday for the last two years.

    Ive reeboted and nothign seems to work. Anyone has this happened to them?
  2. mikejfrd macrumors regular

    Jun 8, 2009
    Yeah I'll get that every now and the too with certain accessories. If you turn the screen off with the top on/off button and then plug it in, it usually works. Weird...
  3. javiwankenobi thread starter macrumors member

    Feb 1, 2009
    Tried it. Didnt work :(
  4. cambookpro macrumors 603


    Feb 3, 2010
    United Kingdom
    Clean the dock connecter with a cotton bud and try again.
  5. javiwankenobi thread starter macrumors member

    Feb 1, 2009
    Cleaned both the dock connector and the iPhone and I'm still getting the error.

    I'm telling you guys it has something to do with my iPhone not having volume a day ago
  6. ideal.dreams macrumors 68020


    Jul 19, 2010
    The problem sounds software related. Have you considered restoring the phone to factory settings?
  7. javiwankenobi thread starter macrumors member

    Feb 1, 2009
    I have, but I am afraid I won't be able to jailbreak again. I'm on 5.0.1
  8. TriJetHero macrumors 601


    Oct 13, 2010
    you have your blobs and APTicket saved for 5.01? if so you can restore with 5.01

    did you try noaccsplash in cydia?
  9. javiwankenobi thread starter macrumors member

    Feb 1, 2009
    Got the blobs. Never Heard of APTicket or accsplash...
    Googling it
  10. splintah macrumors member

    Jan 19, 2005
    same thing with a jbl speaker dock

    this is soooo annoying

    i have the same thing
    - iphone 4 latest os (nothing jailbroken or smth)
    - jbl iphone dock with speakers (this round ufo saucer thingy (very standard jbl speaker dock))
    jbl onstage micro i think

    does not work anymore - accessory not supported - i mean - W . . . . T . . . . F !!
    this is REALLY annoying

    you buy apple because it just works
    this kind of defeats the purpose of buying apple stuff
  11. blitzer09x87 macrumors 6502

    May 19, 2013
    same here, "accessory not supported", will definitely switch to another company for my next phone.
  12. felixthedog macrumors newbie

    Oct 2, 2013
    Not Supported by this Iphone

    I have an Iphone 4s running IOS 7.0.2! I bought two, not one but two, Ihome alarm clocks. I get the "This accessory not supported by this Iphone."

    I thought the first ihome alarm clock was giving me this message because it wasn't compatible with the 4s. Nothing on the box said good for "Iphone 4s." It charged my iphone so i kept it using the phone alone to sound alarms. But it would not play music, or auto sync the time and date.

    This second one I bought, the Ihome id45, clearly states on the box that it is made for the Iphone 4s. But alas, I get the same error message. The phone charges on the alarm clock, but the apps and music don't play through the alarm clock.

    I have turned my 4s phone on and off, I have performed a soft reset, I have performed a hard reset. I have cleaned both the docking port and my cell phone port with a Qtip. Nothing.

    So, I got my wife's phone, an Iphone 4 running IOS 6.1.3, and slipped it into the dock on the alarm clock. It works fine. All features are available.

    Can anyone give me some advice on what to do now?
  13. Ishimaru35 macrumors newbie

    Mar 25, 2014
    Hi guys!
    I've got the same trouble, but there is one simple decision: if you have a plastic connector installed on your JBL OnStage, just throw it away and it works perfect!
    I think it's just because the length of connector of JBL OnStage is not enough to make it work properly.
    Sorry for my English and greetings from Russia!

Share This Page