Accidentally deactivated screensaver with terminal

Discussion in 'Mac Basics and Help' started by raevynn, May 24, 2008.

  1. raevynn macrumors newbie

    Joined:
    May 24, 2008
    #1
    Hello,

    I've had my MBP for about a month now. Yesterday I tried some with terminal, and I think while I was trying to set my (word of the day) screensaver as the desktop background, I might have accidentally deactivated it. All I know is that since today the Screensaver isn't activated anymore after the usual 5 minutes. The display just goes to sleep after about 15 minutes.

    I tried to change the System Settings for the screensaver, but that doesn't help either. It's still set for the screensaver to start after 5 minutes, but it doesn't start. How can I activate it again?
     
  2. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #2
    It would be useful to know what you typed in the terminal.
     
  3. raevynn thread starter macrumors newbie

    Joined:
    May 24, 2008
    #3
    This, a few times because of some typos:

    /System/Library/Frameworks/ScreenSaver.framework/Resources/ScreenSaverEngine.app/Contents/MacOS/ScreenSaverEngine -background
     
  4. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #4
    That command only start the screensaver, so it shouldn't really be a problem. I tried it now on my macbook and it works fine. After clicking control c to terminate the program in the terminal the desktop goes back to normal and the screesaver startup automatically as expected (setting in the pref panel).

    A stupid question. have you tried restarting the mac? Also try to use one of the standard screensavers that came with the OS, to be sure it's not an issue with the one you are using.
     
  5. raevynn thread starter macrumors newbie

    Joined:
    May 24, 2008
    #5
    Oh I forgot to mention that it didn't actually work. The screensaver wasn't on my desktop after I typed that command, so I tried a few more times and then just abandoned the idea.

    I've tried changing the screensaver to other ones, which didn't work either. The "word of the day" screensaver I'm using is one of the Standard ones that come with Leopard...
     
  6. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #6
    Try deleting the plist file(s) in your home directory:

    ~usr/Library/Preferences/com.apple.ScreenSaver.Engine.plist
    ~usr/Library/Preferences/com.apple.desktopscreensaver.<name of screensaver>.plist

    Then reboot and try setting your screensaver in System Prefs.
     
  7. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #7
    Sorry there is a typo in the paths I specified from my previous post:

    ~usr should be ~user in both lines.
     
  8. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #8
    There is a Widget that does what you want to do. No need for terminal.

    Just go to the Apple Widget page and search.
     
  9. raevynn thread starter macrumors newbie

    Joined:
    May 24, 2008
    #9
    I solved the problem by restarting - no idea what really went wrong. I guess I should restart my MBP more often... :rolleyes:
     
  10. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
  11. JNB macrumors 604

    JNB

    Joined:
    Oct 7, 2004
    Location:
    In a Hell predominately of my own making
    #11
    Unix Rule #1: Do not type ANYTHING in Terminal if you don' t know exactly what the result is. You can easily thrash a lot more than a screensaver there.

    Unix Rule #2: Nothing is ever by accident. Ever.

    Unix Rule #3 (The Elevator Button Rule): If, after entering a command, nothing happens, re-entering it will not convince the system that you're really serious.

    Unix Rule #3a: Typos should be avoided, as it still may mean something (see rule #1). Ctrl-C is your friend.

    ;)
     
  12. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #12
    Rule 4: Unix is "case sensitive" meaning you can inadvertently type a command flag in the wrong case (upper and lower case have different meanings) and do some serious damage.

    Rule 5: If you don't know what you are doing, DON'T DO IT!
     

Share This Page