Accidentally tried to copy a folder to a sub-folder within it.. Original folder Gone

Discussion in 'OS X Mountain Lion (10.8)' started by samth3mancgp, Jan 27, 2013.

  1. samth3mancgp macrumors newbie

    Joined:
    Aug 29, 2012
    #1
    I have no idea where I should post this.. So I have an NTFS formatted Internal SATA drive that had over 100GB of ProTools sessions on it within a folder called "ProTools Sessions". I had two finder windows open and I was trying to move a few files at the root of the drive to one of the session folders within the main Folder containing the sessions. I did realize that I also had the main sessions folder selected at the root of the drive.. so it was trying to copy a folder to a sub-folder within it.

    Obviously finder locked up big time and must have had no idea what to do. The main session folder had 100s of Gigabytes of files in it. It wasn't responding at all so I restarted finder from the activity monitor. Now the entire session folder is gone.

    Any ideas? I am trying to run Data Rescue on it to see what happens.. This really sucks. :confused:
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    This is what backups are for. Hopefully, you have a backup that you can restore from. If not, it may provide incentive for you to start a regular backup routine.
     
  3. samth3mancgp thread starter macrumors newbie

    Joined:
    Aug 29, 2012
    #3
    Luckily it is all old ProTools sessions, from over a year ago. I do have backups for everything that is current paying work, but not these. They still are good to have around, I was planning to re-mix some things when I had some free time. We'll see what the Data Rescue thing can do. I was surprised that doing something as mundane as restarting finder would cause the entire deal to just disappear. :eek:
     
  4. TheEasterBunny macrumors 6502

    Joined:
    Jan 22, 2013
    Location:
    Delaware
    #4
    I was curious what would happen if I did the same thing. (you know how that worked out for the cat...). So I tried it! With two empty folders just in case, of course. It popped up a message saying you can not copy a folder into one of its sub-folders. This was almost immediately.
    I would guess the finder was busy with something else and that's why it took a long time. I know every time I have restarted the finder it says something to the effect of "if you do this all unsaved work will be lost".
    Bottom line, your copy/move command probably wasn't the cause of the hesitation, and the force quit of the finder caused the loss of data (unsaved work).
    This made me think for a minute though, thanks!
     
  5. larrylaffer macrumors 6502

    larrylaffer

    Joined:
    Aug 1, 2009
    Location:
    Los Angeles
    #5
    Which solution were you using to give you write access to the NTFS file system? I would place the blame on them.
     

Share This Page