Ack! Can't open "Mac Help" at all!

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by sjcaguy, Jan 22, 2004.

  1. sjcaguy macrumors regular

    Nov 24, 2003
    Hello all. I'm having a vexing problem. I can't open the plain-old "Mac Help" from the help window. The help windows will pop up in other apps-- iTunes works fine, for example.

    But from the desktop, I can't open "Mac Help". If i go up to the menu and click on it, it opens up what looks like a blank "help" box and then closes it very quickly. Basically, the help viewer for standard mac help (from the help menu in finder) quits right away.

    Please help me!
  2. sjcaguy thread starter macrumors regular

    Nov 24, 2003
    more info: i checked the console and noticed a HelpViewer crash on 1/10/04.

    Now I need to know how to fix it. Please Please help. Thanks.
  3. sjcaguy thread starter macrumors regular

    Nov 24, 2003
  4. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    Thanks for sharing that information with us.

    I'm surprised that .Mac users haven't had the same problem since they all have Virex.
  5. mainstreetmark macrumors 68020


    May 7, 2003
    Saint Augustine, FL
    I almost always have more luck with Google than with the built-in help systems. Help always seems so terribly slow.
  6. yamadataro macrumors 6502

    Yeah, I agree. Why is that help program soooooooo slow? My first instict always tells me I should open help, but it's so slow that I always have to force quit and go google.

    Is it unusually slow on just my Mac???
  7. Beechside macrumors newbie

    Aug 15, 2004
    Mac Help problem resolved

    Greetings all.

    Thanks for your help since I had the same problem.

    Tried repairing permissions, moving help files from my own signon (since other sign-ons on my machine worked OK), checking crach reporter logs and so on.

    in the end, I moved all the help files from the Computer/Macintosh HD/Library/Documentation/Help folder to my desktop and moved them back in again. Not sure of the exact process since I was trying to diagnose but I think the key steps might have been:

    Move all file from system help folder to desktop
    Clicked on desktop
    Started help (Cmd-?) - naturally, window was empty but at least it started
    Moved all the files back again.

    Bingo! Help worked for all apps.



Share This Page