ACL missing, permissions differ, error 10810

Discussion in 'macOS' started by naserke, Jun 29, 2010.

  1. naserke macrumors newbie

    May 15, 2010
    I am having a problem with Macbook when connected to external hard drive. Finder stops responding and I have to force quit. message it gives is error 10810. I could not move files to and from external hard drive. This is a big problem as my internal hard drive is full.

    I have bought a new hard drive and created an image of my internal hard drive on new one, so I can install a new one. I used restore function in disk utility to create an image. I tried "verify permissions" on new new hard drive (I haven't installed it yet), and it is giving me hundreds of lines of error. Mostly they starts with " ACL missing on "system/......" There are also few messages like "permissions differ from ......".

    One message is "Warning: SUID file System/library/coreservices/remotemanagement/ has been modified and will not be repaired".

    I have tried "permissions repair" and looks like it repaired all the "ACL missing on.." and some "Permissions differ from....". But "Warning:SUID file....." error was't fixed.

    I reran "verify permissions" now and and it still shows two "permissions differ from....." errors and one "warning:SUID...." error.

    permissions error is "permissions differ on system/library/frameworks/javaVM.frameworks/versions/1.6.0/resources/javaplugincocoa.bundle/content/resurces/javadeploy.jar" should be -rw-r--r--, they are lrw-r--r--.

    second persmissions error is similar with ending like "", should be -rwxr-xr-x, they are lrwxr-xr-x.

    what these errors mean and any suggestions to correct them?
  2. naserke thread starter macrumors newbie

    May 15, 2010
    Thanks Calderone... Could suggest something on error 10810
  3. calderone macrumors 68040


    Aug 28, 2009
    That is a common issue which typically involves connecting to SMB shares. Are you connecting to any SMB shares?
  4. naserke thread starter macrumors newbie

    May 15, 2010
    I have seagate external drive connected with firewire. I don't know what SMB is. I am just hooking it directly. It used to work but not from last few weeks.
  5. OJAck macrumors newbie

    Jun 12, 2013
    What was the fix? Can I back up this disc as a disc image without destroying -- erasing -- other content on that backup disc? Can I just store the disc image in a folder on a 6 TB RAID and leave the surrounding data on the drive safe?

    Thanks for your much needed help. I'm about to panic.

Share This Page