Acrobat Pro doesn't auto open PDF's

definitive

macrumors 68000
Original poster
Aug 4, 2008
1,970
720
I'm using someone else's computer at the moment which has Acrobat Pro X installed, and have it set as default viewer for PDF's. Whenever I double click a PDF, it launches the app, but doesn't load up the PDF. Only way to open PDF's in it is by clicking File > Open.

On my own computer, I have an older version of Acrobat Pro which works just fine. I checked through settings, and nothing stands out that might be interfering with the file.

Anyone deal with this issue before?
 

MechaSpanky

macrumors 6502
Sep 11, 2007
311
137
I have had the same issue with Photoshop. When I double click a Photoshop file, it launches Photoshop (the application) but Photoshop won't open the file unless I go to File>Open. Funny thing is, Illustrator works just fine. In fact all of the other CS applications work just fine for me, except Photoshop. I just thought it was a bug but if someone knows the answer to definitive's question, I too would also like to know.
 

McKs

macrumors member
Apr 8, 2003
55
0
I have had the same issue with Photoshop. When I double click a Photoshop file, it launches Photoshop (the application) but Photoshop won't open the file unless I go to File>Open. Funny thing is, Illustrator works just fine. In fact all of the other CS applications work just fine for me, except Photoshop. I just thought it was a bug but if someone knows the answer to definitive's question, I too would also like to know.
What probably will work is dragging the file from the Finder onto the app's icon in the Dock.

For a more permanent solution, try rebuilding the LaunchServices database with a utility like Onyx (http://www.titanium.free.fr/)
 

definitive

macrumors 68000
Original poster
Aug 4, 2008
1,970
720
What probably will work is dragging the file from the Finder onto the app's icon in the Dock.

For a more permanent solution, try rebuilding the LaunchServices database with a utility like Onyx (http://www.titanium.free.fr/)
Tried both suggestions without any success. Also tried rebuilding the launch services through a Terminal command, which didn't solve the issue either. I can't find anything on Google regarding this issue either...
 

MechaSpanky

macrumors 6502
Sep 11, 2007
311
137
McKs,

I'm just like definitive, I also have tried dragging the file and dropping it onto the icon but it doesn't work either. Dragging and dropping a file onto an applications icon works in every other application that I have (Adobe products as well) but it doesn't work for me with Photoshop. It used to really make me crazy but now I've gotten used to just going to Photoshop and the using the File>Open (although it is slower).

Mecha
 

NuttyBoy

macrumors newbie
Jun 7, 2012
3
0
Tried both suggestions without any success. Also tried rebuilding the launch services through a Terminal command, which didn't solve the issue either. I can't find anything on Google regarding this issue either...
I am having the same problems, only way to open PDF files is opening Acrobat then choosing file/Open, same for closing them just clicking cross on top left of document does nothing have to choose file close. This also happens when I create a PDF proof in Indesign and set Indesign to view PDF once created. Acrobat opens but just to welcome screen where you again have to choose open/file etc etc.


Also can not close welcome screen by clicking cross on top left.

I have tried disabling both splash and welcome screen on load up but still does not directly open file.

Have just updated Acrobat to latest update 10.1.3 which has not solved this, also on Lion 10.7.4.

This is an absolute pain when creating files in Indesign...

NuttyBoy
 

Droid80Sa

macrumors newbie
Jun 11, 2012
1
0
Last week one of my clients came in with the same problem and mine started doing the same on Friday. This morning I used the uninstaller in the Acrobat folder and then re-installed. It all seems to be working fine now. I will keep you posted if the problem returns. ( Side note: all was fine until I installed CS6. )
 

lotuseater99

macrumors newbie
Jun 12, 2012
3
0
Not working for me

Yes, I'm having the same problem with Acrobat Pro. It won't open PDF files directly, even though that is the default viewer...
 

NuttyBoy

macrumors newbie
Jun 7, 2012
3
0
Last week one of my clients came in with the same problem and mine started doing the same on Friday. This morning I used the uninstaller in the Acrobat folder and then re-installed. It all seems to be working fine now. I will keep you posted if the problem returns. ( Side note: all was fine until I installed CS6. )
Tried the uninstall and re-install same problems.. Installing from CS6 so maybe thats the problem.

Will try download direct from Adobe to see if that works.

Will update.

No still no joy... Assume something to do with CS6
 
Last edited:

shiroamada

macrumors newbie
Jun 20, 2012
1
0
Same happen to me install with CS6, updated to 10.1.3 the problem still occurs.

Installed separately installation file - Acrobat X Pro, then it work perfect.

Suspect something wrong with CS6 installation.
 

the read

macrumors regular
Nov 25, 2009
198
1
I'm having the exact same issue on CS6.

I'm now trying the upgrade to 10.1.3 as other suggested. If I dont post again it because its worked.
 

Foulger

macrumors newbie
Jun 16, 2000
17
1
New Zealand
I was in the same boat

I tried Applejack and repairing permissions and using Onyx to rebuild the launch services to no avail. This on Acrobat X 10.1.3. I uninstalled it and reinstalled Acrobat X from a CS 5.5 standard installer. This worked perfectly and I am now back to normal. I would guess there is a bug in the CS6 installer and that a patch will hopefully come out as a future update. Perusing Mr Google, it seems that lots of folk are having the same problems so if you buy CS6 and you have acrobat X already installed, don't uninstall it in favour of a new fresh install because you will be up the creek without a paddle. BTW after I uninstalled it I did install it again from the CS 6 install and it was just the same, so I uninstalled it twice (including the preferences) just to prove the point. I suppose to take it to the nth degree one could try and install it on its own from the CS6 install DVD to see if it works OK before installing the rest of the software? Long winded but I hope this helps.
 

swamyg1

macrumors regular
Dec 11, 2007
184
31
Just wondering if anybody has managed to fix this issue. I updated Acrobat Pro to the latest version 10.1.4 but still can't open files with double click.
 

t-munny

macrumors newbie
Dec 2, 2010
4
0
I'm still having this problem with 10.1.4. A search on Adobe's help site had this to say:
In Mac OS, you may not be able to open a PDF created in Windows by double-clicking the icon. Instead, choose File > Open With > Acrobat.

I've tried reinstalling different versions, which is how I discovered that Adobe's download site offers a free trial version download for Windows only.

I don't know whether to keep waiting, or just give up.
 

firedept

macrumors 603
Jul 8, 2011
5,623
491
Somewhere!
Tried the uninstall and re-install same problems.. Installing from CS6 so maybe thats the problem.

Will try download direct from Adobe to see if that works.

Will update.

No still no joy... Assume something to do with CS6
CS6 version not the problem. Just letting you know. Definite bug though. Acrobat Pro current version is working fine for me. PDF's open immediately for me. Lots of bugs to still be worked out in CS6.

I am having problems with After Effects CS6 not wanting to render a SWF file that includes any kind of jpg, png, tif, psd, etc. Filed bug report with Adobe and they are currently working on a fix. This bug everyone will have.

Lucky I still have CS5 around to work with when I find a bug. Contact Adobe let them know about it. Maybe there is something they can do for you.
 
Last edited:

0985829

Suspended
Oct 25, 2012
1
0
Acrobat 9 works on my computer

I was having the same issue with Acrobat X so just started using 9 again and so far so good.
 

mtwilson

macrumors newbie
Nov 4, 2012
4
0
peru
Same issue withAcrobat 11

I am having the same issue with Acrobat XI PRO (11.0.0). I had 10.x installed when I first noticed the problem, so I ran a system clean with Onyx rebuilding permissions and launcher files, no change, so I uninstalled Acrobat 10.x and re-installed, no luck, so then I downloaded Acrobat XI Pro and did a clean install, same situation.

I can only open pdf's from within the app and I have to use close from the file menu to close the file as the left upper red-dot close button does not work. I have searched Adobe forums and can't find a single mention of this issue, but there are many references to it online. I am on a MacBook Pro running OS X 10.8.2 Mountain Lion.

This really sucks as opening mail attachments and such require boring down to the file location or saving to a new location to open easily from within the app. I have notified Adobe, but, of course, no response. Just curios if anyone else had made any headway on this issue.
 

simu

macrumors newbie
Nov 6, 2012
1
0
stop gap solution

I am experiencing the same thing. First of all, download the free acroabt reader so you're not stuck - then at least no more manually opening...

Reader will open it all - once installed- as desired.

Hope this helps to lessen the pain - somewhat.
 

billdakelski

macrumors newbie
Jul 25, 2008
23
0
10 and 11

Same problem here with x and xi.
In addition the tools menus will not respond when clicked.
Also, app quits unexpectedly.
Also, will not quit from the dock icon
 

swamyg1

macrumors regular
Dec 11, 2007
184
31
I uninstalled and reinstalled... Problem is gone and Acrobat is working fine.

Looks like this is the only solution as far as I know.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.