ActivateMMS2G not working for me. 2G 3.0

Discussion in 'Jailbreaks and iOS Hacks' started by vlj9r, Sep 27, 2009.

  1. vlj9r macrumors member

    Joined:
    Feb 18, 2007
    #1
    Since AT&T is no longer sending the link with the username and password to view MMS messages, I decided to jailbreak a 2G. I had been upgraded to 3.1 but I used iTunes 9 to downgrade it to 3.0. I then ran redsnow to jailbreak the phone. At times it got stuck waiting for the phone to reboot so I had to unplug the usb cable and re connect to cause the reboot. Once jailbroken I updated Cydia and installed ActivateMMS2G. Rebooted the phone but when I would go to Settings, MMS I never saw the option to enable it. I also try to install APN edit but the it fails to fully install. Script error half way thru the install.

    Other Cydia apps loaded fine and ran without a hitch.

    Seems like I may have to downgrade something else besides the firmware.

    Any ideas?

    Thanks,

    jr
     
  2. nickels macrumors member

    Joined:
    Oct 3, 2008
    #2
    Same here, running 2G iphone 3.0 JB.
    Installed ActivateMMS2g in Cydia.
    Installed latest 5.5 ipcc file.
    I get the camera icon but the messages never send - always get the red !

    Tried to change the settings in network, tied custom ipcc files, nothing ever works. I'm on AT&T network.

    Does anyone have this working on their original iPhone?
     
  3. jvice09 macrumors member

    jvice09

    Joined:
    Jun 24, 2009
    #3
    ive done the same and still cant send or receive. im on 3.0.1 but that shouldnt matter and also on at&t
     
  4. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #4
    try to fill in your settings/general/network/cellular data network see if that works.
     
  5. pcpshortbus macrumors member

    Joined:
    Mar 23, 2008
    #5
    i also have a 2g on 3.0. i downloaded the acivatemms2g app, but didnt have the cellular data tab under settings. so from there i downloaded supreme prefrences 3.0 to be able to do this, but never got the "enable mms" option under messaging. when this didnt work, i deleted both apps from cydia. now i still have the picture icon by the message box, and i have the enable mms tab and i also have the cellular data tab, but with no apps that would enable all this stuff on a 2g 3.0. weird, but im wondering if i set the right apn and data settings will the mms work?
     
  6. jvice09 macrumors member

    jvice09

    Joined:
    Jun 24, 2009
    #6
    well i tried this when i had the 5.1 carrier file and i was able to fill out the cellular data network myself but with no luck. i updated to the 5.5 carrier file and now there is no longer the option to change the cellular data network manually i just assumed at&t automatically filled in the settings to enable mms. no success either way, has anyone else on the at&t network got their mms working on their 2g with activatemms2g? any step by step guides? do i need to change my account through at&t?
     
  7. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #7
    Yes but i have T-Mobile. Works fine. Might be just everybody trying to use their new application this weekend for you AT&T users.
     
  8. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #8
    i was able to use this app for my brother's 2g running 3.0.1 and MMS from Tmobile.
     
  9. jvice09 macrumors member

    jvice09

    Joined:
    Jun 24, 2009
    #9
    so any at&t success stories for 2g? whats your setup?
     
  10. slickmacke macrumors newbie

    Joined:
    Mar 6, 2008
    #10
    I'm in the same boat with getting MMS on my 2G.

    I've been able to get the MMS option in the 'Messages' settings, but have not been able to get the 'Cellular Data' option under 'Settings>Network'. I've tried updating to the new 5.5 carrier file and using the benm trick, but no luck.

    How do I get the 'Cellular Data' option to come up? Is it the carrier file? Something else that I'm missing?

    If anyone has any suggestions, I am more than thankful. Thanks!
     
  11. nickels macrumors member

    Joined:
    Oct 3, 2008
    #11
    The Cellular Data as a setting seems to be tied to the carrier data file. I could change the settings in 5.1, but upgraded to 5.5 and it disappeared. With 5.1 I tried a variety of settings that I found on the web and none of them worked. I upgraded to 5.5, and the ability to adjust the settings disappeared. SO I will go back to 5.1 and see if the manual override settings come back, but it doesn't really matter as none of the settings I tried have made a difference.

    So, it likes like MMS has been disabled by AT&T for 2G iPhones. Someone should take them to task for claiming hardware limitations of the original iPhone as the reason, as that is a straight up lie.
     
  12. xsecretfiles macrumors 6502

    Joined:
    Aug 1, 2008
    #12
    yup i couldn't make it to work with my at&t sim card phone, but it works great with my sister's T-mobile card. weird
     
  13. nickels macrumors member

    Joined:
    Oct 3, 2008
    #13
  14. jvice09 macrumors member

    jvice09

    Joined:
    Jun 24, 2009
    #14
    bump
    i know mms works on the 2g model for tmobile, i setup my roommates phone and it works fine. anybody out there get mms working with AT&T network with their 2g? ive tried just about everything, different carrier files, different settings, no luck.
     

Share This Page