Activator/lockinfo causing home button issues

Discussion in 'Jailbreaks and iOS Hacks' started by kenkamm, Jan 17, 2011.

  1. kenkamm macrumors regular

    Joined:
    Oct 25, 2008
    #1
    I've done a search and read about this a bit, but I'm still not sure how common this issue is.

    When I have lockinfo installed (and thus activator) my home button will not wake the device after it's been sleeping for more than a few minutes unless I press it twice. I did a full restore to stock, re-jailbroke, and installed only lockinfo and the problem came right back. If I uninstall activator (which uninstalls lockinfo, because activator is required for it) the problem goes away.

    Questions:

    1) Can lockinfo be run somehow without activator? Is the problem actually caused by activator, or is it lockinfo? (I have not tried installing activator without lockinfo yet.)

    2) Is there an alternative to lockinfo that doesn't require activator?

    Thanks-
     
  2. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #2
    I have the same issues with the home button
     
  3. cs0373 macrumors member

    Joined:
    Oct 8, 2010
  4. fishmd macrumors 68000

    fishmd

    Joined:
    Jun 18, 2008
    Location:
    Sunny South Florida
    #4
    I have this issue as well, however so do a ton of other people who are not jailbroken. There is a huge thread in the general iPhone discussion board here as well as a couple on Apple support forums. There has been debate as to wether or not it is software VS hardware. Some people have gotten phones replaced because of it and the problem goes away, but may return in their new phone as time goes by. For me I have noticed whenever my home button really stops responding well, if I go and reboot the phone, it gets significantly better again. This makes me still think it is more a software issue. However, as I said before, people have the problem who are not jailbroken too, so it is unlikely to be Activator/LockInfo.

    If you really want to troubleshoot it, restore to new phone and leave it in an unjailbroken state. Then see if you ever get the problem. If not, then jailbreak and add things one at a time only and see if you can narrow it down.

    Good luck. :cool:
     
  5. cyclone84 macrumors regular

    Joined:
    Jul 19, 2006
    #5
    I thought I was crazy until I read this thread. My home button would often take 2 presses to activate the phone and I was convinced that my hardware was failing. After uninstalling Lockinfo, the problem went away. It's a shame because I like everything else about Lockinfo.

    FWIW, I did not uninstall Activator.
     
  6. kenkamm thread starter macrumors regular

    Joined:
    Oct 25, 2008
    #6
    I can assure you my issue is not the jailbreak. The issue is very repeatable. Without lockinfo and activator, the home button behaves as normal despite the jailbreak. Sounds like the issue may actually be lockinfo and not activator, based on the previous post.
     
  7. kenkamm thread starter macrumors regular

    Joined:
    Oct 25, 2008
    #7
    I've purchased and installed intelliscreen, which works fine and doesn't cause the home button to malfunction. I like lockinfo better though, so I hope they realize this as an issue and fix it.
     

Share This Page