Activity App not working correctly

Discussion in 'Apple Watch' started by Euneiro, Sep 30, 2016.

  1. Euneiro macrumors newbie

    Joined:
    Sep 30, 2016
    #1
    Hi, I'm very new to Apple Watches. In fact like 2 hours ago new. Anyway I just got the old watch (the Space Gray Sport) from a friend who sold it to me. He wiped it and I set it up and paired it with iPhone 7. I went to the Activity App on the watch and went through the initial setup and it told me to go the Activity App on the phone to finish. I opened the app and it's just a black screen with the little loading circle animation in the middle. I left it alone for about 15 minutes and still nothing. I unpaired the watch and re-paired again setting it up again as a new watch and still the same thing. My iPhone 7 is on the 10.1 beta so I thought it might be an issue with that so I also updated the the watch to the watchOS 3.1 beta but still same issue after unpairing and re-pairing once again. Kind of at a loss at this point on what to do. Any help would be appreciated. Here's a screenshot of the Activity App open though it's not really helpful for anything.

    http://imgur.com/a/tlVP1
     
  2. Julien macrumors G4

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #2
    The image is of the Activity app on you iPhone. Have you restated your iPhone?
     
  3. Euneiro thread starter macrumors newbie

    Joined:
    Sep 30, 2016
    #3
    Yes I have. And yes the image is of the Activity App on the phone because the watch says go to that app and that's what happens when I do.

    Also of note is that in the Apple Watch App under Health when I try and enter my Birthday, Sex, Height, Weight, etc. none of it saves. As soon as I go out of that menu and back in it's all gone. I've tried uninstalling and re-installing the app and as I said above have wiped and re-loaded the watch, even as a new watch, and it does nothing.
     
  4. Julien macrumors G4

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #4
    Did your friend completely remove the :apple:Watch from their iCloud account and then un-pair it properly?
     
  5. Euneiro thread starter macrumors newbie

    Joined:
    Sep 30, 2016
    #5
    Yes it was unpaired from the old phone correctly. Interesting to also note that the Health App on the iPnone, which I've never used before getting the watch, also won't save any of my details either. Just from a cursory Google Search before posting this thread I've found other people with the same issues but haven't really found an answer as to why and how to fix it.
     
  6. Euneiro thread starter macrumors newbie

    Joined:
    Sep 30, 2016
    #6
    OK, I've finally managed to fix this after much trial and error. In case anyone searches in the future for a similar issue maybe this will help them.

    Turn off iCloud backup
    Make an Unencrypted Backup via iTunes
    Turn off Find My iPhone
    Restore Backup (NOT Restore iPhone) using that backup that was just made in iTunes
    Everything should work now, including the Health App saving details and the Activity App connecting to the watch
    Turn Find My Phone and iCloud Backup back on

    Also after I turned off iCloud backup I deleted my backup on iCloud so I wouldn't accidentally restore it in the future and made a new one after everything was working again.
     

Share This Page