Activity Monitor CPU idle percentage wrong

Discussion in 'iMac' started by t_e_c, Feb 13, 2010.

  1. t_e_c macrumors newbie

    Joined:
    Feb 13, 2010
    #1
    I have a new, week 7, 27" iMac with 2.8 quad core CPU. Activity Monitor shows the "% idle" number jumping anywhere from 49% to 99% (but usually stays around 49%), when I'm actually 99% idle. The "% user" and "% system" numbers are less than 1% when the computer is idle. They just don't add up to 100%. Does anyone else see this?
    The left top of the computer is hotter than any computer I have had before.
    This is the third computer that Apple has sent with this problem. Apple Care just says to send it back.
    Any ideas?
     
  2. TMRaven macrumors 68020

    TMRaven

    Joined:
    Nov 5, 2009
    #2
    Hm. My week 7 i7 doesn't get that problem. I dunno what to say.

    As far as the computer being hot at the top, that's what it was designed to do.
    It filters air through bottom and blows it all out of top-- the frame is aluminum too, so it conducts heat very well (ie getting hot)

    The two hottest parts of the computer are also at the top (power supply and gpu) As long as the internal temperature readers aren't showing very high temperatures, I wouldn't be too worried about it.
     
  3. eyalg macrumors newbie

    Joined:
    Feb 13, 2010
    #3
    My Activity Montior idle is the same...

    I noticed this a few days ago...

    My Idle also gets down to 49% for a few seconds then back up to 99 then back to 49 etc...

    But Top (the equivalent of Activity monitor in the terminal) and iStat widget always show 99 idle.

    I think it is a bug with the Activity monitor, It doesn't know how to handle the i7.

    My computer is overall very cold. (istat hottest temp is the GPU Diode and it goes up to 50 degrees Celsius) but the top is pretty cold overall...
     
  4. t_e_c thread starter macrumors newbie

    Joined:
    Feb 13, 2010
    #4
    27" iMac i7

    Thanks for the info. I will try iStat on the next one they send to see if it gets different results.
     
  5. t_e_c thread starter macrumors newbie

    Joined:
    Feb 13, 2010
    #5
    CPU Activity Monitor total usage % does not add up. 27" iMac i7

    Thanks for the info. I will try iStat on the next one they send to see if it gets different results.
     
  6. eyalg macrumors newbie

    Joined:
    Feb 13, 2010
    #6
    Any Updates ?

    Hi t_e_c !

    Was wondering if you have any updates ???

    I'm wondering if I should contact Apple for a replacement too...


    Thanks !
     

Share This Page