Ad hoc network wiped out regular network connection

Discussion in 'Mac Basics and Help' started by Stevee00, Jan 7, 2011.

  1. Stevee00 macrumors newbie

    Stevee00

    Joined:
    Aug 13, 2008
    #1
    Hello,

    I've searched and don't see anybody else with this problem. I tried to set up an ad hoc network on my MBP so I could use TouchAble with my new iPad. But now I can't get my MBP (or iPad) to see my home wifi network.

    (TouchAble is a music performance app on the iPad that controls Ableton Live on the MBP. It works on an ad hoc network so the combo will work on gigs without depending on local wifi.)

    I set up a new network ok, with a password. The iPad saw it, but before I tested it further I wanted to make sure I could reinstate my regular network. So I tried switching back to the regular wifi. No dice! The MBP sees the network, but I can't log in. It acts like the password is wrong. Same on the iPad.

    Yes, the network works. I didn't make changes to the settings in my router, and my iPhone still sees it with the same password.

    I tried a tip I found online and deleted the network preferences file (com.apple.smb.server.plist) and rebooting. No dice. (The system didn't write a new one, as I had expected; I had to reinstate it from the Trash). I rebooted a few times, both MBP and iPad. Nope.

    Help! What's going on here? 1) How can I get my MBP to see my network, so I can switch back and forth from the ad hoc to the local network. 2) Ditto for the iPad.

    MBP is new. All systems and versions are up to date. No other funny stuff with the network--it's been stable for two years. Everything is stand-alone; this is in my home office. I'm the admin. (But I'm not a techie, so if you start talking about IP addresses and subnet masks, please be clear what I should try.)

    Any suggestions muchly appreciated.

    Steve
     
  2. Stevee00 thread starter macrumors newbie

    Stevee00

    Joined:
    Aug 13, 2008
    #2
    Update

    After spending a few hours on this problem, including an hour on the phone with a senior Apple tech who was equally stumped, we found a partial solution. At the suggestion of the Verizon tech who we patched in to the call, I reset my router (pushing in the reset button), reset passwords and security protocols. That worked. I could get the MBP and iPad to see the wifi network again.

    I tried setting up the ad hoc network again (while the Apple tech was still on the phone), and sure enough, it knocked out the ability of the ipad and laptop to connect to the wifi network. Just as before, nothing would work, and the devices could see my wifi but kept complaining of a wrong password. A total reset of the router (and clearing netword settings on the devices) and new passwords enabled the devices to see my wifi again.

    So the good news is that we were able to repeat the symptoms. The bad news is nobody understands why it happened like this. We even got Verizon involved (they own the router) and they didn't have any suggestions. Firmware and everything is up to date.

    The Apple guy is going to do more research and see if he can explain it.

    Maybe somebody here who really understands networking can offer some suggestions based on what we know now.

    I still want to set up an ad hoc network, but I'm not going to try again until I know I can do it without screwing up my wifi.

    Steve
     
  3. marky141 macrumors newbie

    Joined:
    Feb 10, 2011
    #3
    Did you ever sort this out?

    Hi, I have exactly the same problem. I want to use touchAble but it keeps wiping my wifi out everytime i try to create an ad-hoc network. Did you ever manage to overcome this problem?

    cheers
     
  4. Stevee00 thread starter macrumors newbie

    Stevee00

    Joined:
    Aug 13, 2008
    #4
    Marky,

    No, I don't have any good answer yet that can help you. I haven't tried setting up the ad hoc network yet. But I expect it will work when I do because I ditched the old Verizon router and bought an Airport Extreme. I figure if I'm using Apple wifi equipment all the way, it should work. I'll post here when I get back into it.

    In the meantime I've just used my resident wifi system (coming from the Airport Extreme), not an ad hoc network, and got TouchAble, TouchOSC, and LiveControl to work between my iPad and MBP. It's tricky enough, I wanted to make sure I got that part working before going back to the ad hoc network issue.

    From what I see so far, TouchOSC + LiveControl (they work together) gives way more flexibility than Touch-Able.

    Steve
     

Share This Page