Adapter plugged in and light turns green but doesnt actually charge.

Discussion in 'MacBook' started by Leysquare, Mar 27, 2010.

  1. Leysquare macrumors newbie

    Joined:
    Mar 27, 2010
    #1
    Hi i need some help here.
    It all started this evening where i plugged my adapter into my macbook to charge. Instead of the usual bright orange light, it was a very dim orange and was barely visible and flickers occasionally. When plugged in, it stated "Not Charging".

    After awhile, i decided to try again but this time it was a dim green. Still not charging. I tried airing it for a bit, and tried again. This time it didn't light up at all. Just a while ago, i realized it was able to charge again (Bright Orange).
    However, i noticed it never seemed to turn green so i tested it out by removing my battery. Even after removing, the lights below the battery were on and moving as if it was still charging. (Hope you understand what i mean)
    After a while it stopped though.

    So i tried draining my battery. It went till about 3hrs (at 100% its 4hrs),
    and i tried charging it again. Immediately after connecting it, the display went to show "Fully charged" with the bright green light. I disconnected it and it stayed at 100% for a while before changing to 90%.

    Sometimes it works perfectly while other times it just decides to go bonkers.
    I will try using a diff adapter tomorrow to see if the problem is in the adapter. (Probably is)
    Anyone has any experience with any of the symptoms above? :(
     
  2. Leysquare thread starter macrumors newbie

    Joined:
    Mar 27, 2010
  3. velvetelvis macrumors 6502

    velvetelvis

    Joined:
    Oct 26, 2007
    #3
    i'm having the same problem. and have no idea why.
     

Share This Page