Adblock not working on youtube anymore?

Discussion in 'MacBook Air' started by Redrum509, Nov 27, 2013.

  1. Redrum509 macrumors regular

    Joined:
    Feb 20, 2012
    #1
    So for the past couple weeks Adblock has not been blocking any ads on youtube. Anyone else having this problem? Thanks.
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    Weird, although it seems to be from the same maker, Safari "AdBlock" seems to let a few YouTube ads through lately, but Chrome "AdBlock" seems to still work fully.

    Try using Click to flash, and set Media player to QuickTime. No ads.
     
  3. Redrum509 thread starter macrumors regular

    Joined:
    Feb 20, 2012
  4. Jimbo47 macrumors 6502a

    Joined:
    Jun 21, 2010
    #4
    Safari Adblock hasn't ever worked on videos for me. The chrome version does though.
     
  5. dbroncos78087 macrumors regular

    Joined:
    Feb 27, 2013
    Location:
    Northern Virginia
    #5
    The method that adblock uses to hide ads from your view probably won't be useable for YouTube ads. I believe they are technically embedded into the video, which means the whole video would need to be blocked.

    This is the embedded link from a YouTube ad that I got on a video:

    Code:
    <iframe width="640" height="390" src="//www.youtube.com/embed/k-CGH052TnM" frameborder="0" allowfullscreen></iframe>
    I don't believe that is the type of text that adblock uses. Anyone who knows more about it that can offer an opinion?
     
  6. Redrum509 thread starter macrumors regular

    Joined:
    Feb 20, 2012
    #6
    Kinda weird how adblock was working like a charm for the past months I have had it. Than either when either Mavericks or the big youtube update Adblock stopped blocking ads. Now There isn't a video that I don't get a garbage ad.
     
  7. phrk macrumors member

    Joined:
    Mar 26, 2012
    Location:
    Germany
    #7
    Ads are not embedded into the video. They are just a short videoclip infront of the video. How else would you be able to skip the ad after 5 seconds? The Adblocker prevents the ad-video from playing.

    AdBlock for Firefox still does the job.
     
  8. dbroncos78087 macrumors regular

    Joined:
    Feb 27, 2013
    Location:
    Northern Virginia
    #9
    I would be very hesitant to blame Mavericks for Adblock not working. I won't rule it out, but I don't think it would be the top of my list for causes.
     
  9. stark4 macrumors 6502

    Joined:
    Oct 14, 2008
    Location:
    Florida
    #10
  10. david83 macrumors newbie

    Joined:
    Mar 11, 2014
  11. Crimsoncrusade macrumors newbie

    Joined:
    Feb 26, 2014
    #12
    I take it you are having this problem with Chrome??
    There are two versions of "flash" on chrome in mac. The inbuilt and the system one.
    type this in the chrome address bar
    Then under "Adobe Flash Player" you will find two entries both named shockwave flash differing by only type
    one of them will be PPAPI and the other will be NPAPI

    Disable the NPAPI entry

    Example:-
    [​IMG]
     
  12. Quotenfrau macrumors 6502

    Quotenfrau

    Joined:
    Mar 6, 2011
    #13

Share This Page