Resolved AdBlocker blocking searches with "ads" in them

Discussion in 'Jailbreaks and iOS Hacks' started by Qaanol, Feb 16, 2013.

  1. Qaanol, Feb 16, 2013
    Last edited: Feb 16, 2013

    Qaanol macrumors 6502a

    Joined:
    Jun 21, 2010
    #1
    Update: Solved. It was AdBlocker being overzealous. Manually white-listing the search engines fixes the problem. I wasn’t seeing the issue in Chrome or Dolphin because I had not enabled AdBlocker for them.

    Former thread title was
    Censorship: "Cydia ads" Safari search blocked



    On my iPhone 4S running iOS 6.1.1 jailbroken, I am experiencing what appears to be censorship in MobileSafari.

    When I search for "cydia ads", "sbsettings ads", and similar terms on my phone, Safari gets redirected to "blocked:blank" with a blank page. I have tested Google, Bing, and Yahoo, and the same thing happens with all of them.

    Is this a known occurrence?

    The problem is confined to Safari. Both Chrome and Dolphin are able to complete those searches just fine.

    I have a number of tweaks installed, and I'd like to know if this undesired behavior is due to a 3rd-party tweak, or whether Cydia and/or SBSettings have started being evil, or what.

    What can I do to prevent my searches from being blocked?
     
  2. TM WAZZA macrumors 68000

    Joined:
    Sep 18, 2010
    Location:
    Hamilton, New Zealand
    #2
    Just tried it and getting that too.

    Also, for some reason when I type out words in the google box on the top right of Safari, I'm not getting the suggested searches. What's up with that

    ----------

    On some word searches it works eg. I type in "enga" and it brings up the suggested search "Engadget"

    Most words such as "samsu" is blank on the suggested searches
     
  3. stephen1108 macrumors 65816

    Joined:
    Sep 30, 2007
    #3
    This doesn't happen to me.... I was just able to search "Cydia ads" in safari no problem!
     
  4. monderick macrumors member

    Joined:
    Jun 30, 2010

Share This Page