Add me to the hang problems with Mavericks list

Discussion in 'OS X Mavericks (10.9)' started by sixxmum, Mar 8, 2014.

  1. sixxmum, Mar 8, 2014
    Last edited: Mar 8, 2014

    sixxmum macrumors 6502a

    sixxmum

    Joined:
    Aug 15, 2010
    #1
    I have an MBP with 8G of RAM and a 750G hard drive. It's only a year and a half old. Since installing Mavericks toward the end of 2013, I've been getting an increasing amount of hangs while in programs or trying to open them. The lag will sometimes be a couple of minutes before I can do anything. This isn't with anything fancy running (typically mail and safari and word).

    I've been considering a trip to the genius bar, but am not sure what they can even do when it is a problem that isn't consistently replicable. Some days it happens 30-40 times, and some days it's more like 10. If it was just the ball, no big deal, but the lag time is annoying.

    Is the general thought on fixing this issue right now that it requires a wipe of the hard drive and clean install?
     
  2. davidinva macrumors 6502a

    Joined:
    Mar 29, 2009
    Location:
    Shenandoah Valley of Virginia, USA
    #2
    I bought my MBP in January and installed Mavericks. Had some migration problems from my old Macbook, but it is after going to 10.9.2 that I have the same problem as you. Mostly with Photoshop Elements that will hang when opening or saving a photo. I usually have to Force Quit PE, and then restart. Works ok for time, then back to the same. I use PE a lot, so it's frustrating.
     
  3. davidinva macrumors 6502a

    Joined:
    Mar 29, 2009
    Location:
    Shenandoah Valley of Virginia, USA
    #3
    Anyone else having the problem with Photoshop Elements and Mavericks?

    Any others having this problem with PE and Mavericks? It's still happening to me. I have read that Adobe won't update a version of PE, just issue a new version. Will PE 12 work ok with Mavericks? They both came out about the same time.
     
  4. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #4
    Mavericks is optimized for SSDs and has trashy performance on HDDs.

    Lag is normal if you have a HDD. I used to have an early-2011 MBP with 2.3Ghz quad core i7 and 16GB of RAM, but the 7200rpm drive meant that booting would take 2-3 minutes and opening apps was laggy. And there was just a general lag to everything. When the Samsung 840 Pros came out, I tossed the 7200rpm HDD into the trash can and bought a 512GB 840 Pro. It absolutely flies now, with 11 second boot times and instant app launching.
     

Share This Page