Add remote in Apple TV greyed out

Discussion in 'Apple TV and Home Theater' started by jonnyb, Jul 11, 2008.

  1. jonnyb macrumors 65816

    Jan 21, 2005
    Rye/London, UK
    So I've got my iPhone 3G and I've updated my Apple TV to 2.1 but when I go to set up a new remote on the Apple TV, 'add remote' is greyed out. Can anyone tell me what I've done wrong?

  2. ayale99 macrumors 6502

    Dec 6, 2007
    I had that problem at first too. You have to have your iphone on with the remote app running. AppleTv will then recognize it. Then all you have to do is enter the passcode.
  3. jonnyb thread starter macrumors 65816

    Jan 21, 2005
    Rye/London, UK
    Hmm..I've done that but it's still greyed out. It's driving me nuts!
  4. kevinbal macrumors regular


    Feb 28, 2006
    Storrs, CT
    I'm having this same issue but I think it is the setup that I have that is the problem. I've got an airport express hooked up to the airport extreme. I keep the b/g devices on the express and N only devices on the extreme. I'm not quite sure how to alleviate this problem at the moment.
  5. omni macrumors 6502

    Jan 20, 2008
    I had the same issue and I finally figured out what's going on.

    Update itunes to 7.7 obviously
    Update AppleTV obviously
    Update iPhone/iTouch obviously
    Download and install Remote app

    Go to settings, general, remotes on the appleTV and then open up the Remote app on the iPhone and push settings on the App until you get to choose a library. From there everything should light up like a christmas tree. Mine is already working but you might need to click on Add Library to make everything light up. Either way you should get a 4 digit code from the remote app that you need to input into the AppleTV itself.
  6. jonnyb thread starter macrumors 65816

    Jan 21, 2005
    Rye/London, UK
  7. Kyle-N macrumors newbie

    Aug 2, 2008
    tried it - still no good

    I'm running into the same problem and tried your advice with no luck.

    updated my iTunes, updated my AppleTV, updated my iPhone 3G, I even deleted and re-installed the Remote App, but "Add Remote" in my AppleTV's remote settings is "greyed out."

    No problem adding my iTunes library, though. And, I tried adding my iTunes library first or adding AppleTV first. I tried every combination of opening AppleTV's setting then Remote App Settings, or vice versa.

    Any ideas?

  8. benlee macrumors 65816


    Mar 4, 2007
    Make sure you are connected to the same network.

    Open up the settings on Apple TV first. Then open up the remote app.

    Try rebooting both if still not working.
  9. rules909 macrumors newbie

    Aug 3, 2008
    Maybe too simple but... make sure you are connected wireless.
    Cable won't work.
  10. Monetthecat macrumors newbie

    Mar 14, 2008
    Connecting by ethernet (cable?) works perfectly. I'm connected via ethernet and have no issues using my iPod Touch as a remote
  11. rules909 macrumors newbie

    Aug 3, 2008
    Really? My Iphone remote can't find the apple tv when connected wireless. It works well wireless. Weird..
  12. rules909 macrumors newbie

    Aug 3, 2008
    Does anyone have a solution to this problem?
    I would love to get it to work via Ethernet.
    My setup:
    Internet->Router(wired)->iMac->wireless to Iphone
    ->Router(wired)->Apple tv

    So when I unplug the Ethernet cable from my atv and switch to wireless the iPhone remote works.

    Help appreciated.
  13. ladysman macrumors regular

    Jan 29, 2008
    I know, i know, this is a very old thread but i'm having the same problem. Although my apple TV is on wireless and the remote app will NOT connect to it unless I put it on the network via LAN cable.

    I have 2 appleTV's and one of them is on LAN and one is wifi. The one on the LAN i have zero issues with the Remote App. The one I have on wifi, i can't use the remote app unless i hook it up via a LAN cable connection. As soon as I disconnect it, it shows our iphones but the remote app won't connect to control it.

    Anyone else have this problem?
  14. jwcoleman macrumors newbie

    Oct 4, 2009
    Same problem. Mac Pro ethernet, Apple TV ethernet, Airport express ethernet. Remote recognized itunes library and appletv before snow leopard.
  15. MyMacDaddy macrumors newbie

    Nov 29, 2009

    You have to go to settings in the Remote app on your iPhone (or iPod Touch) and Add Library. A series of 4 numbers will come up. This threw me because I'd just added a library which linked to my music library. I thought that it was prompting me to add those numbers again on my Mac.

    But instead I went to the remote setting on my Apple TV and...lo and wasn't greyed out anymore. I just entered those numbers on the TV and it worked. :)

Share This Page