Adding bookmarks in Safari defaults to first Folder

Discussion in 'macOS Sierra (10.12)' started by eyedee, Feb 7, 2017.

  1. eyedee macrumors newbie

    eyedee

    Joined:
    Oct 13, 2012
    #1
    Here's an odd one I can't seem to find a fix to. Ever since upgrading to macOS Sierra when I go to add a bookmark in Safari the default location is always the first Folder located in the favourites list. The standard default for bookmarks is obviously the Favourites list itself, not into a folder within the favourites list, and it's an unnecessary hassle having to select the Favourites list every time.

    Any ideas please?
     
  2. eyedee thread starter macrumors newbie

    eyedee

    Joined:
    Oct 13, 2012
    #2
    I guess this is a fairly uncommon error? I've still not found a fix. I'd really appreciate it if anyone knows how to solve it.
     
  3. eyedee thread starter macrumors newbie

    eyedee

    Joined:
    Oct 13, 2012
    #3
    I'd still really appreciate help to fix this issue. Having to manually select 'Favourites' every time I want to save a bookmark is becoming tedious. I've searched the net but haven't found any remedies to the issue.
     
  4. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #4
    To add a bookmark to the favourites, just drag and drop the name of the site (or the URL) from the address bar to the favourites bar.
     
  5. macintoshmac macrumors 65816

    macintoshmac

    Joined:
    May 13, 2010
    #5
    That is a workaround, not a fix (to this issue).

    I do not like to drag a lot, and do not have the favourites bar open. So, in that case, the workaround means reducing my screen real estate to some extent.
     
  6. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #6
    I am unable to reproduce your problem : when I use the "share" button as I guess you do, the "default" folder is the last I used, so if it is "favourites", it will be "favourites" the next time.

    eyedee said:

    "Ever since upgrading to macOS Sierra when I go to add a bookmark in Safari the default location is always the first Folder located in the favourites list."

    I do not have this behavior.
     
  7. macintoshmac macrumors 65816

    macintoshmac

    Joined:
    May 13, 2010
    #7
    I have this same bug. Surprised you do not. :) Enjoy! This is on a fresh install (for different reasons, not this), so the bug is going to stay with me and the thread starter for some time, it seems.

    Out of curiosity, could you please name a folder beginning with D or C or B or A, and then see the result? I will do it and report too.
    --- Post Merged, Feb 12, 2017 ---
    Just tested. It defaults to the first folder, regardless of name.
     
  8. Bruno09, Feb 12, 2017
    Last edited: Feb 12, 2017

    Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #8
    I have created 4 folders named test1, test2, test3, test4.

    As previously said, the "default" folder when I bookmark a site is the last I have used.

    For example if I use test3, the next time, test3 is the default folder.

    EDIT 1 : okay, I have the "bug" know : when I use "favourites", the next time the default folder is the first folder in the list.
    So, it looks like "favourites" is an exception, as it refuses to stay as default folder.
    No idea why...

    Another nice workaround is to use the "+" icon that shows up in the left of the address bar, favourites is the second item after the reading list.
    Can be done with one finger only : click the +, move the finger downwards to "favourites", release.
    Done.

    EDIT 2 : just found an actual "fix".
    In Safari / Preferences, change "New windows open with" and "New tabs open with" from "Favourites" to : Top Sites.
    Now "favourites" sticks as default folder when I use it to bookmark a site.

    I was tweaking Safari preferences to solve this problem, that is why I did not have the "bug" first, then I had it after some changes, and finally fixed it by reverting to the previous settings.

    Note : this behavior also exists with El Capitan, not only Sierra.
     
  9. macintoshmac macrumors 65816

    macintoshmac

    Joined:
    May 13, 2010
    #9
    Totally solves it, yes. Thank you! I find the Empty Page option (that I used to keep long, long many years ago) quite refreshing. Just hadn't kept it lately. Back to it and problem solved!
     
  10. eyedee thread starter macrumors newbie

    eyedee

    Joined:
    Oct 13, 2012
    #10
    Just got the chance to revisit this thread and am so happy to find your fix Bruno09. It works! I really appreciate you taking the time to help solve the bug. Thank you!

    That's made my day.
     

Share This Page