Adding Explicit Music to Playlists

sdwaltz

macrumors 6502a
Original poster
Apr 29, 2015
743
991
Indiana
Can't seem to find anyone with this exact issue.

I have zero restrictions on whatsoever, so adding explicit music to my library shouldn't be a problem...however, whenever I add an explicit song to my library, the "clean" version is what gets saved. It doesn't seem to do this for every song, but it definitely does for some.

The weirder part is that if I search Apple Music for the song, I can listen to the explicit version. I save it in my library, and it shows the clean version as the song being saved again.

Anyone else having this issue or know how to correct it?
 
  • Like
Reactions: cansuds

cansuds

macrumors regular
Jan 19, 2018
128
120
It’s bugged. People are complaining about it. I can’t play explicit music either. I went through every tab on the restrictions menu - and nothing. No solution. Restart doesn’t fix it either.
 

RobHandz

macrumors newbie
Aug 10, 2018
27
15
Still present in iOS 12.1. Try the following. It worked for me:

- Open iTunes Store
- Search for Explicit content (Song, Album etc. whatever...)
- Try a purchase (doesn't matter if it's greyed out)
- You should get a prompt that you have enable explicit content
- Confirm
- Money
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.