Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Jumpie

macrumors 68020
Original poster
Jul 7, 2008
2,027
1,651
Atlanta
I have to iPhones: a work one and a personal one. The work one was the first to get wifi calling and now my personal has wifi calling. When I try to upgrade to wifi calling on my iPad, it only recognizes my work phone the same thing happens to my rMBP. How to do I change to my personal phone?

I signed out of iCloud on my work phone but the iPad and rMBP only want to do it with my work number.
 

robnbill

macrumors regular
Jul 5, 2007
118
34
Northern VA - Fairfax Area
If I understand you correctly you want to switch "Calls from iPhone" to your personal iPhone number from your work iPhone.

On your work phone I would make sure "Calls on Other Devices" under "Phone" is turned off - turning that off will not affect your wifi calling on that work iPhone. On your personal iPhone turn on "Calls on . . . " and in the list you should be able to select which devices (iPad, MBP, other iPhones) you want to allow calls on.
[doublepost=1463841541][/doublepost]Let me add one more thing. I also turned on wifi calling on my iPad under FaceTime (If I recall) - it activated after a minute or so. Then I was able to receive calls from my iPhone.
 
Last edited:

Jumpie

macrumors 68020
Original poster
Jul 7, 2008
2,027
1,651
Atlanta
If I understand you correctly you want to switch "Calls from iPhone" to your personal iPhone number from your work iPhone.

On your work phone I would make sure "Calls on Other Devices" under "Phone" is turned off - turning that off will not affect your wifi calling on that work iPhone. On your personal iPhone turn on "Calls on . . . " and in the list you should be able to select which devices (iPad, MBP, other iPhones) you want to allow calls on.
[doublepost=1463841541][/doublepost]Let me add one more thing. I also turned on wifi calling on my iPad under FaceTime (If I recall) - it activated after a minute or so. Then I was able to receive calls from my iPhone.

Thanks
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.