Additional possible work around for "stuck updating" apps

Discussion in 'iOS 7' started by mkstewartesq@co, Jun 13, 2013.

  1. mkstewartesq@co macrumors regular

    Jun 30, 2007
    Like many people, I've had at least one "stuck updating" app that just wouldn't come "unstuck" and complete the update. For some of these apps, the trick of turning on wifi to complete the update worked, for others, manually re-triggering the update via the App Store app worked. However, for Instagram, the app was just stuck and no method worked, and I was unable to delete the app via the "deleting the icon" method (tapping the icon to get the "X" and deleting.)

    Have not seen the following additional workaround in any threads I have reviewed:

    The following worked for me to delete the app and re-download it (you WILL lose any saved data - for me, this was just my saved login credentials on Instagram, so no big deal).

    - Go to Settings > General > Usage.

    - Scroll down to the "stuck" app (if not shown, hit "Show all apps")

    - Find the "stuck" app - it will likely not display any usage information - and click on it

    - on the next screen, there will be a button to "Delete App"

    - Delete app via this method, go to App Store and re-download. (Actually, for me, Instagram was there in the App Store with an option to "Update" instead of "Install" - I hit "Update" and it reinstalled and now works fine.)

    Hope this helps.


Share This Page