Address Book and iCloud

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by SMargaret, Jan 19, 2012.

  1. SMargaret macrumors newbie

    Joined:
    Jan 18, 2012
    #1
    Hello there,

    I have recently made the switch over to iCloud.

    I have 2 macbook pros a macbook air and an iPhone.

    The address book is working very well with the 2 pros and the iPhone.

    However, on the macbook air the address book lists 2 lots of contacts:
    All On My Mac &
    iCloud.

    I can click on All On My Mac and only those contacts show up (but changes have been made to a few email addresses and they do not show up)

    I can click on iCloud and only one set of contacts shows up (the correct ones with the changes)

    Or I can click All Contacts and it duplicates.

    So ... how do I hide or delete All On My Mac contacts as I only want to use iCloud contacts - as the other devices are using this.

    I have selected iCloud as the default account in system preferences.

    Also, in the macbook air all the birthday subscriptions have now doubled up!

    Please help!

    Thank you in advance!
     
  2. scottzc macrumors newbie

    Joined:
    Sep 30, 2012
    #2
    Hide "On My Mac" section in Contacts Address Book

    Open Contacts preferences, and set Default Account to iCloud.
     

    Attached Files:

  3. newagemac macrumors 68020

    Joined:
    Mar 31, 2010
    #3
    If you're sure they are all in iCloud and correct, you can just delete the ones from "All on My Mac". Those are just the ones stored "locally only" on that particular Mac. And like the previous poster said, make sure you set iCloud to default so that when you add new contacts they aren't created as local only.
     
  4. JuBe macrumors member

    Joined:
    May 28, 2009
    #4
    Is there any way to hide or minimize the "On My Mac" contacts? All they do is cause me to accidentally move over and put my contacts in there instead of iCloud (my default).
     

Share This Page