Address Book, constantly 'updating index'...

Jebaloo

macrumors 6502
Original poster
Sep 12, 2006
296
0
Hi, my HD collpased on me a few weeks ago and now that i got it back i've been busy getting it back to it's previous state. Most everything went back into place with ease from a disk image i'd thankfully made a coupe of weeks before my laptop broke.

My address book however is now playing up. I had a more recent back-up of it online than on my disk image, so I went into 'Application support', and then 'Address Book' and simply replaced the entire contents of the folder with the contents of my backed-up version.

The problem now is that whenever i open up the address book and try to search the applcation stalls and at the bottom of the window it flashes, 'updating index', continually.

I don't knw just to leave it to do this for a long period of time, or whether there is some way of rebuilding the index manually/automatically.

Does anyone have any ideas?

Thanks.
 

Jebaloo

macrumors 6502
Original poster
Sep 12, 2006
296
0
Sorry to bump this, but I still have the problem and no replies so far.

Thanks for looking.
 

blodwyn

macrumors 65816
Jul 28, 2004
1,148
1
Portland, Oregon
Sorry to bump this, but I still have the problem and no replies so far.

Thanks for looking.
There are a couple of Address Book preference files in User/Library/Preferences. You could try renaming them and then try Address Book again to see if that works. Alternatively you could try unchecking 'Contacts' in the Spotlight preference pane, and then re-checking it to see if that re-builds the index.
 

Jebaloo

macrumors 6502
Original poster
Sep 12, 2006
296
0
Hi there, Thanks for your advice.

I've tried both of the above things and nothing has changed unfortunately.

I've also tried backing up the address book and then shutting down, restarting, and then reverting the address book to its back-up.

Still no gain.

Any ideas?
 

blodwyn

macrumors 65816
Jul 28, 2004
1,148
1
Portland, Oregon
Hi there, Thanks for your advice.

I've tried both of the above things and nothing has changed unfortunately.

I've also tried backing up the address book and then shutting down, restarting, and then reverting the address book to its back-up.

Still no gain.

Any ideas?
Hmmmm, my only other suggestion would be to delete the cache files in User/Library/Caches/com.apple.AddressBook
 

Jebaloo

macrumors 6502
Original poster
Sep 12, 2006
296
0
Hmmmm, my only other suggestion would be to delete the cache files in User/Library/Caches/com.apple.AddressBook
Unfortunately that hasn't worked either... Tried everything. Totally stuck. I might have to resort to a trip to a genius bar.

Thank you for your help, any other suggestions appreciated.
 

xUKHCx

Administrator emeritus
Jan 15, 2006
12,587
6
The Kop
This problem got me interested when i first read bt I couldn't find anything so didn't report at the time. Please be sure to post the "fix" if the genius guys find one
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.