address book problem!!! sigh.... what's wrong? help!

Discussion in 'macOS' started by itou, Nov 2, 2009.

  1. itou macrumors regular

    Joined:
    Jan 16, 2008
    #1
    i'm having problems with my address book.
    whenever i'm trying to edit a name, or even just opening my address book entries.. i get this:

    [​IMG]

    what's wrong?
    when i press EDIT, i type in these small spaces (can't see own type) and nothing gets recorded.... the middle pane's fine though. it's only when you look at a contact details that the fields are all screwed up.

    thanks!!!!!
     
  2. eRondeau macrumors 6502a

    eRondeau

    Joined:
    Mar 3, 2004
    Location:
    Canada's South Coast
    #2
    Looks like your .prefs are scrambled. Delete them. Go to your user account -> Library -> Application Support and then delete the entire Address Book folder. Then go to your user account -> Library -> Preferences and delete com.apple.addressbook.plist. YOU WILL LOSE ALL YOUR CONTACTS but at least you'll start with a clean slate.
     
  3. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #3
    This is probably a font problem. Have you made any changes to your fonts recently? It is likely you have font in your user folder that are conflicting with the Systems Fonts.

    I think the font for the name section in Address Book is Helvetica. I would open Font Book, select the Helvetica Fonts and select File --> Validate Font in the Menu Bar. It will let you know if there are conflicts.

    Do not do this. First off all, it doesn't make sense. Second, there is no need to delete your address book. Third, it probably will not fix it and you will have lost your contacts.
     
  4. itou thread starter macrumors regular

    Joined:
    Jan 16, 2008
    #4
    thanks for your replies.
    i honestly thought it was a font problem too, so i downloaded "fontdoctor x" and tried to run a diagnosis. they found some duplicate fonts and have moved the fonts to another folder. i rebooted, and same deal.

    i'll try looking for helvetica neue again tonight.
    if i have it in my font book and it's not the problem, what should i do then?

    it's horrifying to have to delete my address book and manually enter them all over again!!!!
     
  5. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #5
    Don't do this yet:

    Instead of deleting, just copy ~/Library/Application Support/Address Book to your desktop, and maybe another location. Then delete the original. Add a contact and see if you get the same results. You probably will.

    Do this:

    Before doing that. Take initiative with the fonts. Did you install new fonts? A new application like the CS4 Suite which includes fonts? You never answered this question.

    Check your Font folder for Helvetica Fractions, ~/Fonts. (the ~ means your user folder)

    Check /Library/Fonts for Helvetica Fractions.

    Check /System/Library/Fonts for Helvetica Fractions.

    This is an old support document, http://support.apple.com/kb/HT2444, but it notes that Address Book needs Helvetica to work properly, Helvetica Fractions is taking over though.

    This KB explains what you are seeing. http://support.apple.com/kb/TA23044

    In this case, my hunch is that your problem is with the Helvetica Fractions font. If you have Helvetica Fractions (You do). Disable it with Font Book.

    If you make changes, delete your font cache (Terminal):

    Code:
    atsutil databases -removeUser
    For the system font cache:
    Code:
    atsutil databases -remove
    Reboot.

    Other readings:
    http://blog.dreamstime.com/2008/11/27/browser-problem-in-mac-helvetica-fractions_art27962
    http://www.qbn.com/topics/574123/

    A good article on dealing with Font issues.
    http://www.fontgeek.net/blog/?p=6
     
  6. itou thread starter macrumors regular

    Joined:
    Jan 16, 2008
    #6
    thank-you so much for taking the time to explain so well.
    i'll try this at home tonight and keep you posted. :)
     
  7. itou thread starter macrumors regular

    Joined:
    Jan 16, 2008
  8. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #8
    Awesome. Glad it worked for you and you didn't have to delete your address book!
     

Share This Page