Adium and Camino crash on start

Discussion in 'Mac Apps and Mac App Store' started by helpmhost, Jan 4, 2007.

  1. helpmhost macrumors newbie

    Jan 4, 2007

    I am very new to Macs, so please bear that in mind.

    I installed Adium and Camino and everything was working fine. I later installed macgpg and mac GPG Keychain Access. I installed all the programs using my admin account. However, I do not use the admin account for anything other than administration.

    So I logged back in as my regular account, opened GPG Keychain Access and click on Generate (to create my key). GPG Keychain Access crashed. It crashed everytime I open it and click Generate. I temporarily gave up.

    I tried to open Camino and Adium, and they both crash (all my other programs still open successfully).

    I have tried removing the preferences files for all those programs as well as removing the Application Support files for both.
    To be exact:
    ~/Library/Application Support/Adium 2.0
    ~/Library/Application Support/Camino

    Removing all those did not fix it.

    When I log in as the admin, all the programs still work and I can create a GPG key in GPG Keychain Access.

    I created a new regular user account and logged in as that account. Everything works (including creating the GPG key).

    I do not know what else I can do. Please give me some ideas. I do not want to simply move everything to the new account because I would like to know what is the cause so I can fix/prevent in the future.

    If needed, I can post the GPG Keychain Access and Camino crash log. I can't for Adium because it did not create one.

    Some other info:
    -> I have successfully created a GPG key in the command line using gpg --gen-key and can see the keys in GPG Keychain Access (which does not crash anymore because I am not clicking on Generate).
    -> I am not using fink (I know that gpg has special install instructions when installed through fink).

    Thanks for you help.
  2. helpmhost thread starter macrumors newbie

    Jan 4, 2007
    Based on advise from someone, I removed various files and found that if I remove:
    ~/Library/Application Support/AddressBook/
    it solves the problem.

    I had not even noticed, but my Address Book also crashed upon opening it. By removing this file, I lost all my contact (not a big deal as it was a new mac and only had test contacts in there).

    Can anyone tell me how something like this happens?
    As I said originally, I am new to Macs, so I am just wondering if things like this happen often in the mac world.
  3. Compile 'em all macrumors 601

    Compile 'em all

    Apr 6, 2005
    You dont need to logout/login to your admin account just to install programs. If you are running using a regular account and try to install a program, you will be prompted for the username/password of the admin. Plain and simple.

    As well, GNU PG worked for me out of the box with no problems whatsoever. Just try installing programs from your regular account and enter you admin credentials when prompted for them.

Share This Page