Admin on iMac can not Write to Hard Drive

Discussion in 'iMac' started by iriejedi, Dec 20, 2018.

  1. iriejedi macrumors 6502a

    iriejedi

    Joined:
    Oct 4, 2000
    Location:
    Nor Cal
    #1
    I'm stumped....

    on my Moms semi-new iMac - on the hard drive for permissions it says SYSTEM can read write - others read only.... so nothing can be save to the hard drive.

    My Mom is the "ADMIN" account and updating or adding her to the permissions on the "GET INFO" tab - the computer tells me insufficient permissions to make the change.... as if there is a super admin.....

    Tried safe mode.... tried making a new admin account.... tried disk utility....

    has to be something simple....

    Running latest Mac OS and drive has only 50Gigs of 2TB used....

    Any thoughts?
     
  2. jerwin macrumors 68020

    Joined:
    Jun 13, 2015
    #2
    admins are members of the wheel group. That means they can use sudo. But in ordinary circumstances, they can only manipulate their own files.
     
  3. cwanja macrumors 6502a

    Joined:
    Jun 23, 2010
    Location:
    Texas
    #3
    Have you tried resetting the ACLs from the recovery partition? Been a LONG time since I have had to do it (5+ years), but here are instructions from Parallels on how to do it.
    https://kb.parallels.com/en/120432
     
  4. madmin macrumors regular

    Joined:
    Jun 14, 2012
    #4
    Firstly, admin's are members of the admin group (20) not the wheel group, but it does give automatic sudo access by default. The root folder of the drive '/' is not writeable by default and nor should it be. This doesn't sound like an admin problem. System Integrity Protection (SIP) will prevent writing to certain system folders, whether or not you have root access, via sudo via membership of the admin group. Unless you disable SIP via the recovery partition, which you shouldn't do anyway.

    If you want to create extra folders, shared or otherwise, try doing so under the /Users/Shared folder.
     
  5. mikehalloran macrumors 68000

    Joined:
    Oct 14, 2018
    Location:
    The Sillie Con Valley
    #5
    How did you move the files over? You just copied them didn't you? Yes you did and you are now seeing the results.

    Going in and changing permissions on the boot drive is a good way to totally screw up your machine. DO NOT DO THIS!

    If there's any way you can use Migration Assistant to wipe the drive pull everything over, do so. A complete Time Machine restore to the "semi-new" Mac will accomplish the same thing. Any other solution is going to take longer.
     

Share This Page

4 December 20, 2018