Admin password not accepted anymore - but it's correct

Discussion in 'Mac OS X Lion (10.7)' started by taner82, Mar 17, 2013.

  1. taner82 macrumors newbie

    Joined:
    Mar 17, 2013
    #1
    Hi,

    i have a strange problem in Lion 10.7.5:

    My admin password is not accepted anymore in Lion. Whenever i'm asked to enter the Admin password, the window closes (therefore: no "wrong password" message or something else) but the process isn't continuing (for example an installation). There is no change or progression.

    The password is definitely correct, i was also able to change it or use it in the terminal (where it is accepted). But i'm still not able to use it within Lion.
    Tried also to boot in single-user mode and change the password there via "passwd username" but i'm getting a "The daemon encountered an error processing request" error message.

    Read somewhere else, that i should repair permissions and/or try keychain first aid. Tried both but the problem still exists.

    Does anyone have another idea? I really don't want to restore my system... Actually, how can i do this without an installer disc? Purchased my imac with lion pre-installed - i guess i would have to reinstall all my applications?

    Thanks for your help!
    Taner
     
  2. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #2
    Sounds like you've hosed your system somehow. You can reinstall the OS by holding down <command> R at restart.
    It will download the most recent version from the internet.

    I think I'm right in saying that a standard install will leave all you user data, apps and settings in place.

    But even so, you have a backup, of course.
     
  3. taner82 thread starter macrumors newbie

    Joined:
    Mar 17, 2013
    #3
    Thanks for your answer.

    Things got worse with resetting the admin password, i couldn't login to my system since the autologin feature was turned off after that somehow. Well, in the end i managed to enable autologin via the terminal again, but i had enough of this mess -> clean install -> everything is fine now.
     

Share This Page