Admin Problems after installing Lion

Discussion in 'Mac OS X Lion (10.7)' started by crazy$hark, Aug 1, 2011.

  1. crazy$hark macrumors regular


    Mar 24, 2011
    After installing Lion I have a problem with my trash -

    Then i tried to install an app update and it said that i do not have permission to write in the applications folder.
    For some reason I am having admin problems. Here is a picture of my permissions -

    It says that i can only read and for some reason it changed the name Admin to Wheel (as you can see in the picture). Please help :confused:

    P.S. the "Allow user to administer this computer" in Settings -> User&Groups is checked
  2. Ecoh macrumors 6502a


    Oct 30, 2009
    A few years ago, on a 1 week old iMac, I had a similar problem that you had with your trash can.

    I just lived with it for a few weeks. I knew Leopard was being released soon and the people at the Apple store told me to just bring in the iMac and they would install Leopard on it at no charge.

    They installed Leopard and there were so many odd bugs when testing it, they ran diagnostics on the iMac. It turned out the hard disk was defective and they ended up giving me a new iMac.
  3. crazy$hark thread starter macrumors regular


    Mar 24, 2011
    I don't think its my HardDrisk because it worked perfectly before
  4. robgendreau macrumors 68040

    Jul 13, 2008
    The first, and easiest, possible fix is to boot from the disk that cam with your computer and run Disk Utility, and use the repair permissions feature. That might fix some of your problems.

    I believe the group wheel on a Mac includes all administators, and you seem to say you're logged in but in the group everyone with only read permission.

    Are you logged on to the Mac in your administrator account?
  5. Jirv311 macrumors newbie

    Aug 1, 2011
    I think I'm having a related issue. I can't seem to unlock certain options in System Preferences. Such as Login Options. I authenticate, hit OK, and nothing happens.
  6. crazy$hark, Aug 1, 2011
    Last edited: Aug 3, 2011

    crazy$hark thread starter macrumors regular


    Mar 24, 2011
    I only have one account, and yes it's admin. I repaired disk permissions, when repairing it showed (in details) that it was repairing a lot of things but all my problems are still there. There was one error when repairing. Here's the picture of what it said -

Share This Page