administrator permission problems ?

Discussion in 'macOS' started by talf, Feb 22, 2008.

  1. talf macrumors newbie

    Joined:
    Feb 22, 2008
    #1
    Hi
    when i log in with my normal user i cannot empty trash or install web certificate.the certificate is installed but doesn't work.
    everything works fine when i log in as "root" and try to empty the trash or install the same certificate.
    comming from a PC it looks to me like permission problems.

    anybody knows how to fix this ?

    thanks

    tal
     
  2. djinn macrumors 68000

    djinn

    Joined:
    Oct 4, 2003
    #2
    Under System Prefs/Accounts - Does it say Admin under your profile? That might be your problem. If it does you can try doing a disk permissions repair through the Disk Utility.
     
  3. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #3
    It sounds like you don't have administrator access to make such changes on your machine.

    Check them out as the poster above me has instructed and you should find the cause of the problem.
     
  4. talf thread starter macrumors newbie

    Joined:
    Feb 22, 2008
    #4
    thanks guys, it does say admin under my user name and i tried the permission repair before. it didn't help.
     
  5. MacFanBoyIIe macrumors 6502

    Joined:
    Feb 22, 2008
    #5
    Have you tried creating a fresh Admin account, then restarting, login to that new account, open disk utility, repair permissions?

    Or maybe use sudo in the Terminal to repair permissions?
     
  6. dowser macrumors newbie

    Joined:
    Feb 21, 2008
    #6
    I allways used to run disk repair (booting from external disk) 3 times when there were some issues on the 1st one, and it could see different trouble appearing ond the 2nd one, the 3rd run would return a ”no trouble found” kinda string. So i was sometimes also re-running the permission fix, but it was allways OK on the 2nd. But recently it found a whole lot of wrong permissions on the 2nd run. So you might try that, if you didn’t yet.
    As a matter of fact, i had to go in the info window of some files to fix their permissions manually so that they would ”behave themselves”.

    You can use Onyx or another utility to force the finder to show hidden files, then browsing into your home folder, you will be able to check the .Trash info file for permissions. They should be :

    User(me): Read & Write
    everyone: No Access

    You probably can fix that one but chance is there are more and you won’t be able to trace them all.

    Obviously smthg went wrong in your system, but if it is just about your user permission there are some ways to avoid a ”wipe & install fresh” .
    One solution i found is (i’ll try to make it clear, but english is not my main system language ;) ):

    1/ back up your home folder on another volume or USB key, nothing else will be involved in the trick. Keep note of your name and shortname details of the original account

    2/ get in the Accounts Preference Pane and create a new user with admin rights, write down your name and shortname details of the original account and log out of it, then re-log in the new one

    3/ back in the Account pane, erase (completely, you backed it up, didn’t you?) the old user account in the preference pane and reboot.
    The user you have just created, which ID was 502 for the system is now replacing the old corrupted one as the main (and first) user, its new PID is now 501

    4/ create another ”502” fresh user with the exact name and shortname of the original one you have just deleted, and re-log as such (after logging out

    5/ erase the ”dummy” account you have created first, so that the original user name and shortname are bound to the PID 501 user once again.

    I used this trick to have the exact same user as the first and main user in all my machines, so that i never have any access or writing permission troubles when i move some files from a mac to another.


    edit
    Dough! I had to leave my post unfinished and came back later to sum it up, in the meantime MacFanBoyIIe has pointed out what i should have started with!!!
    If you did not (or can’t) repair permissions from the install disc or another boot volume, you might try his trick first. Then you could get back to my trick directly from 3/ if it does not help
    :cool:


    Edit 2

    Of course...

    6/ move your backed-up user files back into your new user account sub-folders
    To be sure you are not missing any invisible stuff (software registration and stuff) use Onyx to make them visible, select all files from each subfolder and drag them to the new one, and choose ”don’t replace” for any pre-existing file . You may also see invisibles files to move as well that have been stored directly in the user folder.

    ;)
     
  7. MacFanBoyIIe macrumors 6502

    Joined:
    Feb 22, 2008
    #7
    That's a great trick to get your user account permissions synched between multiple machines. I'm going to have to try that next time I get a new Mac.

    One note of caution: I've read in other forums/threads that using the install disk to repair permissions is not your best option. Logic being that any updates to the OS itself (10.5.x) could cause problems if you are using an older install disk. Does anyone know of any creedance to that?
     

Share This Page