Advise needed: G-Techonogy G-Drive Q down

PerJensen

macrumors newbie
Original poster
Oct 9, 2012
2
0
My G-Drive Q 1TB is silent (dead) and is not visible on my mac. It's 3,5 years old.

When I press the power on switch (on the G-Drive):
-The activity lamp (on the G-Drive) blinks half a sec, but then remain dark.
-The green lamp (on the external power supply) turns off.

My 3 years warranty has just expired. Planned obsolescence? :-(

How do I check what part is defect?
a) external supply
b) driver card
c) internal disk

Additional info:
I use it as TimeMachine Backup connected with Firewire 800 to my Imac.
I have tried USB connection as well, but with the same result.
I have tried it on my MacBookPro as well, but with the same result.
The disk inside the G-Drive Q is a 7200 rpm Hitachi produced in 2008.
 

maflynn

Moderator
Staff member
May 3, 2009
66,699
33,587
Boston
If you have a drive enclosure, the easiest way to test it, is to pull the drive and put it another external drive enclosure.
 

Mike in Kansas

macrumors 6502a
Sep 2, 2008
962
73
Metro Kansas City
Do you have a another external drive or device with a power brick you could test it with? All of my drives have external power supplies, and they all take the same 12V DC plug, as do my powered speakers. Lots of computer components use the same 12V DC power plug.
 

Fishrrman

macrumors Core
Feb 20, 2009
19,453
6,750
Chances are, the problem is not with the "drive" itself, but has to do with the enclosure the drive is "encased" in.

Poster #2 mentioned buying another enclosure for the drive.

Can you spare $25?

If so, I'd suggest that you consider one of these instead:
http://www.amazon.com/s/ref=nb_sb_n...search-alias=aps&field-keywords=usb+sata+dock
(Many different items shown, they all work the same way, just pick one you like that's cheap)

Once you have the dock, do this:
- Open the old case
- Take the old "core drive" out
- Connect the USB/SATA dock to a USB port
- Put the drive into the dock and turn the dock on
- Does the drive then spin up?
- Does it mount on your desktop?

If so, the drive is still good. I'd suggest you just keep using it in the dock. You can even boot from it that way….
 

PerJensen

macrumors newbie
Original poster
Oct 9, 2012
2
0
Thanks for your help.

I will order a USB SATA dock (Thermaltake BlacX 5G) and test the internal disk.

I hope the error is in the power supply or controller, but time will show. I may be back on this thread.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.