AEBS & 2TB USB (with 2 partitions) Issues

Discussion in 'Mac Accessories' started by Mr.T, Jul 10, 2010.

  1. Mr.T macrumors member

    Joined:
    Jun 13, 2010
    #1
    Greetings. I have a new AEBS and a 2TB WD Elements USB HD.
    I have used Disk Utility to create a 500GB partition (backups) for time machine backups, and a 1.5TB partition (share) to use as shared storage between my Mac Mini and my WinXP Desktop. Both partitions are formatted with HFS+.

    I had planned on using Samba/CIFS to mount the share partition on both os' but for some reason I can only see and therefor mount the backup partition. Also when the drive is plugged into the AEBS the light goes orange, and Airport Utility (on windows machine) complains about the share partition.

    Has anyone seem this before? Or can you offer some advice on how to fix it? Is what I'm trying to achieve even possible? Does the AEBS support multiple partitions?

    Thanks Mike.
     
  2. Mr.T thread starter macrumors member

    Joined:
    Jun 13, 2010
    #2
    Here's the output from the AEBS Log:
    The odd thing is, when I plug the HDD into my Mac Mini directly via USB, the Mac Mini see's it fine and can access both partitions.
    I even ran the Disk Utility tool for health check and it returned that everything was peachy!

    Im pulling my hair out over here!
     
  3. Mr.T thread starter macrumors member

    Joined:
    Jun 13, 2010
    #3
    Ok so I've managed to solve half the issue. I reformatted the whole disk as hfs+, then created 2 partitions starting with the 1.5tb share partition, then the 500mb backup partition.

    The AEBS can now see both partitions, and the green light is back on the AEBS.

    But now when I try to enable Time Machine from my Mac Mini (connected via 802.11n) it cannot see either partition of the 2tb drive!

    I'm so close, but still so far!

    Help!
     
  4. Mr.T thread starter macrumors member

    Joined:
    Jun 13, 2010
    #4
    Ok after some further reading - I believe it is no longer possible to backup OS X 10.6 to an Airport Extreme Base Station with a connected USB HDD (in my case a 2TB Western Digital Elements drive).

    Can anyone confirm this is no longer possible?

    http://docs.info.apple.com/article.html?path=Mac/10.6/en/15139.html

     
  5. Mr.T thread starter macrumors member

    Joined:
    Jun 13, 2010
    #5
    Ok - looks like I've resolved my own issue.

    I've unmounted the drives from my Mac Mini (which auto mounted when I plugged the USB HDD into the Airport Extreme Base Station).

    I think remounted the /share partition as a AFP type, and now it appears in the Time Machine.

    So hopefully someone who is having issues in the future might find some use for this thread.

    To answer my questions:
    A USB HDD with 2 partitions connected to an Airport Extreme Base Station can be used as a Time Machine backup location. You need to ensure the partition is formatted with HFS+ (journalled) file system. You also need to ensure that the Mac mounts the shared drive partition as a AFP (apple filing protocol), and then it should appear in Time Machine.

    Thanks.
     
  6. thecodeman macrumors newbie

    Joined:
    Jan 26, 2011
    Location:
    Western MA
    #6
    same situation

    Mike:

    Thank you for the detailed thread, it perfectly applies to me, when I get home I will verify that I am mounting as AFP.

    Q: did you have any issues entering login/pw to your AEBS? I restarted several times and each time I had to connect to manually connect the server, I'm curious is this is an additional problem I will have to overcome.

    More importantly, how has time machine performed since you posted this thread? If you have had issues with the back-ups than I may just abandon this process and spring for a Time Capsule.

    Thanks again,
    L
     
  7. thecodeman macrumors newbie

    Joined:
    Jan 26, 2011
    Location:
    Western MA
    #7
    Time Machine on 2TB harddrive on AEBS solved!

    I connected a WD (Western Digital) Element 2TB to a previous generation (purchased 2008) Apple Extreme Base Station 802.11n.

    First of all, this person deserves 100% of the credit for the effort they put in to getting this "unofficial / unsupported" method to work:

    http://web.me.com/pondini/Time_Machine/AEQ2.html

    Second of all, while :apple: does have it's talking point of "not supporting" this process, there's plenty of others who do, including Western Digital, who advertise their HDs featuring Time Machine, they even have an install guide:

    http://wdc.com/wdproducts/updates/docs/en/appletimemachine.pdf

    Of course, I ran into a wall during the setup. At the very last step Time Machine refused to connect, I had to download this widgit

    http://web.me.com/pondini/Time_Machine/A1.html

    to show me the log:

    "NetAuthConnectToServerSync failed with error: 64 for url: "

    Searching for answers only showed me smug unix geeks spitting out code. Turns out this was because when I formatted/erased the drive, I had permissions set such that the profile "everyone" could "read only." This means that the Time Machine software could not access the drive to write necessary files.

    So, after you format the drive but before you eject the local disk from your machine:

    In Finder, click on the mounted drive name and press CMD-I (get info). In the bottom of the pane, click on "everyone" name and under privilege, select "read and write." If the lock symbol in the lower right corner of the "get info" screen is closed, then you need to click it and enter your password to make the above changes.

    Now eject and disconnect the drive from you computer, switching the drive to the AEBS. When the AEBS server shows up under "servers," click it and make sure it is "connected," which is accomplished by entering the login and password to manage the AEBS. Once the devices is mounted, proceed to the Time machine menu and proceed normally.

    This procedure is most likely not going to work for everyone, and I can't guarantee it's a permanent solution, but it's the hurdle that I had to overcome. If you disagree with any of this, write down your own solution and maybe you can help somebody else.

    Good luck.
     

Share This Page