AEBS and Canon i9100 - "Printer not responding" - Please help!

Discussion in 'Mac Accessories' started by iMerlin, Aug 23, 2008.

  1. iMerlin macrumors 6502a

    iMerlin

    Joined:
    May 13, 2008
    #1
    Thanks to everyone on these forums, I normally dont even have to post because I find the answers with a simple search. But, I have been searching forums/Apple/Canon for the last 2 days. I usually pride myself on solving things like this but at last, I need to admit when I need help.
    I bought an AEBS yesterday to replace my Linksys WRT54G. I get it home and have it set up in less than 30 minutes, the whole set up process was pain free. I was loving it. But then I get to setting up my Canon i9100 and now it has become a nightmare.
    Currently I dont own a Mac, Im waiting for the possible MBP update next month. With that said, I have 3 PCs on this AEBS. 1 on the LAN, the other 2 wifi.
    So the install instructions for a USB printer on the AEBS involve connecting the printer the the PC first and do a test print (which involves installing the printer).
    Then once you can print, plug into the AEBS and run Bonjour for Windows. Mind you, this step already added the canon to my printers on the PC.
    Well, when I run Bonjour, it sees my Canon (even lists the location as My AEBS) and installs the printer.
    So now I have i9100 and i9100 (copy 2) in my printers page. Well, when I try to test print from i9100, I get printer is offline, which makes sense because the port on that one is still set to USB.
    When I try to test print the (copy 2) I get printer not responding. The port on that one says IP_MyAEBS.local.9100.
    Anyway, everything looks like it installs and sees the printer but here is another thing. When I go into my Airport Utility there is no USB printer listed.

    So I head to apple.com/support/airport to attempt to find help. Numerous articles suggest unplugging the AEBS, turning off the printer, turning the printer back on, then plugging the AEBS back in. This amazingly solved 1 problem, the Airport Utility now shows the i9100 as the USB printer. However, I still can not print to it.

    Ive tried everything I can think of from adding the printer manually using the actual IP of the printer on the network. Ive updated all my drivers. I deinstalled and reinstalled the same drivers. Ive tried this on 3 PCs.

    Anyway, sorry this was so long, but I wanted to make sure I had everything covered.

    Also, thanks to this forum, I can not fricken wait to get my Mac. I ran into a huge problem/scare yesterday when I was hooking up my AEBS, I decided to clean up my office to get ready for my MBP :D and when I connected everything back up, my PC would not boot. I had to get into BIOS and found out somehow my PC decided to change the boot order and put removable media as the first boot device, this could be a problem when there is no removable media. Anyway, I dont foresee having problems like that when I get my Mac. So thanks to all...
     
  2. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #2
    think you have to remove the first printer installed on the windows box, since you mentioned (copy 2). just remove everything thing except the one that corresponds to the existing printer that is set up. hope im making it clear, just delete the duplicate printers.
     
  3. iMerlin thread starter macrumors 6502a

    iMerlin

    Joined:
    May 13, 2008
    #3

    Yeah, thanks for the reply SnowLeopard, Ive tried removing the copies of the printer still doesnt respond. I also tried removing all printers and adding it manually using Bonjour and the print utility and still doesnt respond. Not sure what else to try. I was up way to late last night working on this.
    I wonder if its a driver thing. I tried installing all the drivers I could find, but if the printer is going on the AEBS, does my PC need the Mac drivers??? I dont think so, but ya never know.
     
  4. iMerlin thread starter macrumors 6502a

    iMerlin

    Joined:
    May 13, 2008
    #5

    You know, great minds think a like. I just found this article no less than 20 minutes ago. Thanks for posting the link gsahli. I actually found something close to this on Apples support site but not quite the same. Apples version didnt work but this article has more details so lets hope for the best. Im gonna give it a try tonight when I get home from work.
     
  5. iMerlin thread starter macrumors 6502a

    iMerlin

    Joined:
    May 13, 2008
    #6
    This didnt work either. It tries to collect status for a while before it fails, but it still fails.
    Not sure what the deal is but Im about ready to give up!
     
  6. iMerlin thread starter macrumors 6502a

    iMerlin

    Joined:
    May 13, 2008
    #7
    For anyone interested. I messed with this setup more over the weekend and finally got it working.
    I deleted all printers on my PC. I plugged my i9100 into the AEBS and got the Airport Utility to see it. I had to unplug the usb, shut off the printer, shut off the AEBS, then turn the printer on and plug it in, then turn the AEBS on. Next thing I know, the printer popped up in the Airport Utility.
    I then ran Bonjour which discovered my printer and installed it. But here is what was different, before I tried printing a test page and when it failed I assumed the printer was not installed correctly. But this time I didnt run a test page, instead I went into my Canon EZ Photoprint program and tried to print a picture and wouldnt you know it, it worked. Although, I still get the error message that says printer not responding, but it prints. I still get "failed to print" when I try to print a test page and I think that is because a test page attempts to collect information about the printer, but since it is networked, the printer is incapable of returning info to the PC so it thinks it isnt working.
    Anyway, for anyone who thinks the printer isnt working simply because your test print is failing, just try a different document and you might be surprised!

    Thanks to all for the suggestions and help.
     
  7. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #8
    How many USB ports does the printer have?
     
  8. iMerlin thread starter macrumors 6502a

    iMerlin

    Joined:
    May 13, 2008
    #9
    This Canon only has one USB port.

    Another update, I got my MBP on this past Friday and installed the networked printer and it works like a charm from the MBP, no error messages or anything, just prints and is happy. I still get the printer not responding message on my windows machines, even though it works.
     
  9. Primejimbo macrumors 68040

    Joined:
    Aug 10, 2008
    Location:
    Around
    #10

Share This Page