AFNetworking Errors and warning Will Robinson!

Discussion in 'iOS Programming' started by IDMah, Sep 12, 2013.

  1. IDMah, Sep 12, 2013
    Last edited: Sep 12, 2013

    IDMah macrumors 6502

    IDMah

    Joined:
    May 13, 2011
    #1
    I know it should be simple but can't figure it out. Using AFNetworking-Master.
    downloaded from GitHub.

    But getting these errors.
    I'm not great with Xcode setting, sorry if this is stupid error. very specific instructions are greatly appreciated.

    Code:
    Parse Issue - Expected a type
    for all these: AFXMLRequestOperation.h,AFJSONRequestOperation.h,AFImageRequestOperation.h,AFPropertyListRequestOperation.h,AFPropertyListRequestOperation.h,AFNetworkActivityIndicatorManager.h
    
    also getting #pragma message Directive: SystemConfiguration framework. 
    warning as well.. 
    
    i did disable Arc "-fno-objc-arc"

    Also get parse errors on the ios example project.

    using Xcode 4.2.iOS 5.0 If this is the cause where can I get. AFNetworking for it.


    thanks
    Ian
     
  2. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    I haven't really kept up with AFNetworking but you can submit questions on the github page. You don't say what version of AFNetworking you're using. There appears to be a pull request there to "Fix build against iOS 5.0 SDK" but it may not be what you're looking for.

    https://github.com/AFNetworking/AFNetworking/pull/1217

    To fix the #pragma message problem you need to add the appropriate framework, like the message says, and you need to add the #import statement for the main header file from that framework to your pch file.
     
  3. IDMah thread starter macrumors 6502

    IDMah

    Joined:
    May 13, 2011
    #3
    AFNetworking after 0.1.x - SOLVED.. the isssue

    Issue was with any AFNetworking after 0.1.x basically does not work with Xcode 4.2.

    So I finally found a source of AFNetworking 0.1.x which worked fine.

    https://github.com/AFNetworking/AFNetworking/tree/0.10.x

    Will use that for development, and then sub in the full version for release code.
    because all my main machine is Snow Leopard.

    thanks gang!
     

Share This Page