AFP Guest Access to the Public folder?? howto? 10.5.4

Discussion in 'macOS' started by omega2red, Jul 17, 2008.

  1. omega2red macrumors newbie

    Joined:
    Aug 31, 2006
    #1
    Hello,

    Ive set up AFP so i can share the Public folder.

    my config:
    /Macintosh HD1/Users/myusername/Public

    Share address:
    afp://10.0.0.1/Public

    Permissions:
    Everyone: Read
    myusername: Read & Write

    But when i connect to the AFP Share and select the Guest account when asked for a username it fails to connect. When i fill in myusername/password the connection succeeds.

    How do i enable the Guest account to connect my share?

    I have 10.5.4 client not server.

    Can any1 help me?

    thanks!!
     
  2. robf macrumors newbie

    Joined:
    Dec 21, 2007
    #2
    You should be able find the Guest account under Accounts in System Prefs. You may have disabled it there.
     
  3. omega2red thread starter macrumors newbie

    Joined:
    Aug 31, 2006
    #3
    The "Allow guests to connect to shared folder option" is checked

    i don't understand why it doesnt work.
     
  4. robf macrumors newbie

    Joined:
    Dec 21, 2007
  5. omega2red thread starter macrumors newbie

    Joined:
    Aug 31, 2006
    #5
    i enable it at sharing at the systempreferences.

    i have 3 shares in order of list:
    Macintosh HD2->MyUsername(read/write), Everyone(read only)
    Public->MyUsername(read/write), Everyone(read only)
    myusername(home dir)->MyUsername(read/write)

    when i connect to afp://myip/ it automaticly mounts Macinthosh HD2

    but when i connect to afp://myip/Public/ i get some errors: 6602 uncespected error etc.

    when i connect to afp://myip/myusername/ the home dir share it works with guest access :S
     
  6. Mindflux macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #6
    take your share out of your home folder. users other than yourself cannot read /home/username or anything within it.

    drop that right into /Public off the hard drive and try. That's what I had to do. Atleast that's what worked for me.

    Also you cannot do any ACL editing from the GUI. I had to fiddle with that at one point as well.
     
  7. omega2red thread starter macrumors newbie

    Joined:
    Aug 31, 2006
    #7
    i moved it from /home/usnername
    to /public and it now works like i want it to :p

    thanks you solved my problem!
     
  8. Mindflux macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #8

    :apple: Enjoy! :)
     

Share This Page