After 10.6.3: Cannot write to SMB network drives anymore

Death Warrant

macrumors newbie
Original poster
Mar 12, 2007
19
0
Hello

Since the update to 10.6.3, I'm not able to write to mounted SMB drivers anymore. Reading and copying, as well as changing filesnames does work properly, but I cannot save any new files to the drives.

Following error appears:
The operation can’t be completed because you don’t have permission to access some of the items.

I've checked the NAS (Thecus N5200 Pro), but all permissions are correct. Same thing from a second Mac with 10.6.3 to the sames SMB mounted drivers.

This is very annoying...

Anyone has the same problem?

Thanks
 

pos

macrumors newbie
Sep 3, 2009
14
0
Same here.

HOW can I back out 10.6.3 back to 10.6.2? Anyone ? I Can't work!!


Or a solution?


/Per-Olov
 

maulrat1967

macrumors newbie
Jul 13, 2007
6
0
Hello

Since the update to 10.6.3, I'm not able to write to mounted SMB drivers anymore. Reading and copying, as well as changing filesnames does work properly, but I cannot save any new files to the drives.

Following error appears:
The operation can’t be completed because you don’t have permission to access some of the items.

I've checked the NAS (Thecus N5200 Pro), but all permissions are correct. Same thing from a second Mac with 10.6.3 to the sames SMB mounted drivers.

This is very annoying...

Anyone has the same problem?

Thanks
I have the same issue here with my Iomega NAS ... started right after I updated to 10.6.3 last night.
 

natewsmith

macrumors regular
Sep 9, 2007
123
0
Santa Clara, CA
Have you guys tried any Terminal commands to re-write them?

I couldn't access my external drives and I got them back.

chflags nouchg /Volumes/"drive name"
sudo chmod 1775 /Volumes/"drive name"
echo "done"

Then do this:

sudo chown root "/Volumes/volumename/"
sudo chmod 1775 "/Volumes/volumename/"
sudo -k

If 1775 doesn't work use 775.

This did it for me.
 

pos

macrumors newbie
Sep 3, 2009
14
0
I have the same issue here with my Iomega NAS ... started right after I updated to 10.6.3 last night.
And I have it with/against samba shipped with SuSE Enterprise Server 11 (100% updated).
server:~ # rpm -qa|grep -i samba-3.2
samba-3.2.7-11.9.1
server:~ #

Problem with samba on Redhat Enterprise server as well...

All came with 10.6.3.

Apple! What have you done with 10.6.3?

/Per-Olov
 

pos

macrumors newbie
Sep 3, 2009
14
0
Have you guys tried any Terminal commands to re-write them?

I couldn't access my external drives and I got them back.

chflags nouchg /Volumes/"drive name"
sudo chmod 1775 /Volumes/"drive name"
echo "done"

Then do this:

sudo chown root "/Volumes/volumename/"
sudo chmod 1775 "/Volumes/volumename/"
sudo -k

If 1775 doesn't work use 775.

This did it for me.
Well. Than you have a fault installation/config of Samba.

Also. Please explain why "root" should own the files????? You are not root in MAC OS? Beware that root or the admin user in Samba config is a VERY special user. If I remember it right, everything that is written by a samba admin will be owned by root. Don't config anything as samba admins or root.
I have a share with:
[gem]
comment = Gemensamma filer
path = /data/gem
valid users = +gem, +gemadm, +gemwri
read list = +gem
write list = +gemadm, +gemwri
admin users = +gemadm
force group = gem
create mask = 0660
directory mask = 0770
force create mode = 0660
security mask = 0770


And if I go back to the basics and look at files I OWN the directory I want to create files in. No matter wheter you look at the directory in Linux or under /Volumes/<MYSHARE> in Mac. Also, I am a member of the needed groups. DO I have to tell you it worked just before upgrade to 10.6.3 as well?


/Per-Olov
 

Scorpizz

macrumors newbie
Apr 1, 2010
2
0
I see the same problem here.

Problems started after upgrade osx from 10.6.2 to 10.6.3

QNAP NAS (smb-shares) - Problem
Freebsd (smb-shares) - No problems !

With some of the directories on the NAS, I get the error:
"The operation can’t be completed because you don’t have permission to access some of the items."
- when writing a file to the directory.

Observation:
It seems that I only have the problem when the file has extended attributes !
-rw-r--r--@ 1 [user] [group] 552655 Apr 1 00:55 test.txt
After removing that with "xattr -d [attr name] filename" there is no problem when writing the file to the troubled directories on the NAS !

Questions:
Are all these problems with NAS - due to lack of support for extended attributes on the NAS boxes or a fault in osx 10.6.3 ?
My QNAP is based on Linux, as many of those NAS.
Is the problem seen with a windows server share ?
If so,- could there be a cross platform problem there, as I don't see the problem on the BSD server with SMB shares !?
(OSX have a unix from the BSD-family under the hood, as the FreeBSD)

But,- if OSX had extended attributes enabled in 10.6.2 where everything was working as expected, then I can only see one possible cause, and that is an error in the 10.6.3....

/Gert
 

Ca$hflow

macrumors 6502
Jan 7, 2010
447
67
London, ON
Download Path Finder 5. You'll be able to access your drive find - right click on it and chose get info.

In there you see "alias bit" untick this box and suddenly the drive will work perfectly with Snow Leopard.

Ive yet to try rebooting, mounting and unmounting etc but for now it works.

Remember to hookup your drive via USB first before you use the ethernet. Use if after you fixed the alias bit.

Hope it helps though.
 

CylonGlitch

macrumors 68030
Jul 7, 2009
2,925
109
SoCal
Nope, Pathfinder didn't solve the problem for me. :(

I would get the popup "you don't have permission to this drive" when in iTunes (my iTunes library is on the network drive). That was OK, because 90% of the time it would write anyway. But now, I don't get the popup, AND, I can't get iTunes to write to it. BUT I have no problems reading and writing to it via the Finder.

This is just odd.
 

Scorpizz

macrumors newbie
Apr 1, 2010
2
0
Just saw that when copy a file in a teminal session with extended attr to the NAS, it comes with the error:
"could not copy extended attributes to...."
I then removed the ext. attr. "com.apple.metadata:kMDItemWhereFroms" from the file and then the copy went OK. The file still got some other ext. attr but apparently there is no problem with these....

/Gert
 

brbubba

macrumors 6502
May 20, 2006
486
0
Me too, but on a win7 share. Not only does it not work but it crashes the entire windows 7 machine!!!!!!!!!
 

pos

macrumors newbie
Sep 3, 2009
14
0
Hi

Set "unix extensions = no" i Samba.

It seems Mac OS sometimes writes extended attributes and other unix extension stuff to Samba because Samba announces it's supported. IT seems MAC OS does this more as of 10.6.X. Setting the above mentioned setting in Samba disables all "unix extension" features in Samba and the MAC behaves like a windows computer and also obey "force" file and directory write modes from smb.conf.


More info about unix extensions can be found here:
http://wiki.samba.org/index.php/UNIX_Extensions

For me it solves the primary issue that the file permissions for written files on the fileserver was not correct and as specified in smb.conf (se my earlier post above).

Regards
/Per-Olov
 

drbob49

macrumors newbie
Apr 7, 2010
3
0
Hi

Set "unix extensions = no" i Samba.

...
Same problem with two samba servers (one debian, the other ubuntu) that I could access easily before 10.6.3. - note that my Macbook is a samba client. I can only copy files which have not got the '@' attribute set, to either server - very frustrating!

I tried amending smb.conf in the debian server as suggested above but hasn't had any effect.

Just have to keep looking or hope that Apple fix it!

Bob
 

pos

macrumors newbie
Sep 3, 2009
14
0
How do I check if a file in the MAC has this attribute set?

Give me info about your problem and I will try it as well...


/Per-Olov
 

pos

macrumors newbie
Sep 3, 2009
14
0
How do I check if a file in the MAC has this attribute set?

Give me info about your problem and I will try it as well...


/Per-Olov
Never mind... it was just to use the "xattr" command.... However... Give me info about what type of attribute "@" is? It does not sound like an attribute to me and I cannot find even one file with it.
The attributes looks like:
com.apple.FinderInfo
com.apple.diskimages.recentcksum
com.apple.diskimages.fsck
com.apple.metadata:kMDItemWhereFroms
com.apple.quarantine

etc...



/Per-Olov
 

drbob49

macrumors newbie
Apr 7, 2010
3
0
Never mind... it was just to use the "xattr" command.... However... Give me info about what type of attribute "@" is? It does not sound like an attribute to me and I cannot find even one file with it.
.....

/Per-Olov
This is the result of a ls -al command in the terminal. Of the two files sample.doc cannot be copied from the mac to the samba share whereas test.pdf can.

drwxr-xr-x 4 bob bob 136 8 Apr 20:28 .
drwx------ 22 bob bob 748 8 Apr 20:26 ..
-rw-r--r--@ 1 bob bob 75776 8 Apr 20:28 sample.doc
-rw-r--r-- 1 bob bob 1789356 8 Apr 20:27 test.pdf

Most files in my home directory have the @ attribute (whatever it is) - with the exception of pdf, zip, rar and bz2 files. As a workaround, if I zip up a collection of files they can then be shared - not very elegant though!

Bob
 

pos

macrumors newbie
Sep 3, 2009
14
0
This is the result of a ls -al command in the terminal. Of the two files sample.doc cannot be copied from the mac to the samba share whereas test.pdf can.

drwxr-xr-x 4 bob bob 136 8 Apr 20:28 .
drwx------ 22 bob bob 748 8 Apr 20:26 ..
-rw-r--r--@ 1 bob bob 75776 8 Apr 20:28 sample.doc
-rw-r--r-- 1 bob bob 1789356 8 Apr 20:27 test.pdf

Most files in my home directory have the @ attribute (whatever it is) - with the exception of pdf, zip, rar and bz2 files. As a workaround, if I zip up a collection of files they can then be shared - not very elegant though!

Bob
##On my mac...
sjoholmp:~ sjoholmp$ ls -al /Users/sjoholmp/VMWARE*
-rwxr-xr-- 1 sjoholmp staff 1003 10 Nov 18:01 /Users/sjoholmp/VMWARE-root.sh
-rwxr-xr--@ 1 sjoholmp staff 1012 10 Nov 17:51 /Users/sjoholmp/VMWARE.sh
sjoholmp:~ sjoholmp$


## On my Samba target server (after drag´n drop in MAC to the samba share)
rver:~ # ls -al /home/sjoholmp/VMWARE.sh
-rwxr--r-- 1 sjoholmp sjoholmp 1012 Nov 10 17:51 /home/sjoholmp/VMWARE.sh
server:~ #


No problem....

/Per-Olov
 

ubermusician

macrumors newbie
Sep 29, 2008
3
0
Same problem

I am having the same problem as everyone else, but I am on a college campus and can't just rewrite the permissions on my NAS. Is there any way I can fix my computer to actually connect to the SMB shares on the campus network?

This is really frustrating...

Toby
 

pos

macrumors newbie
Sep 3, 2009
14
0
I am having the same problem as everyone else, but I am on a college campus and can't just rewrite the permissions on my NAS. Is there any way I can fix my computer to actually connect to the SMB shares on the campus network?

This is really frustrating...

Toby
And you are sure it's not the "unix extension" problem? If another guy wrote the file to the file share and you try to modify or delete it you can have problem as the other guys MAC could have ignored the shares _force_ permissions as it's allowed to do so...

I have a MAC 10.6.3 and cannot force a problem against a Samba share at the moment even if I want to... Not after I fixed the unix extensions flag...


So what it the same as everyone else? Explain?

/Per-Olov
 

ubermusician

macrumors newbie
Sep 29, 2008
3
0
So what it the same as everyone else? Explain?

/Per-Olov
My apologies. I skimmed over the last portion of the thread because it was mostly the first few posts that seemed relevant to me.

My problem may be slightly different. I can no longer connect to the Samba shares, much less write anything to them now that I have updated to 10.6.3. The shares seem to be fine, as others can still connect with Win7 (at least—I haven't talked with anyone else on campus).
 

pos

macrumors newbie
Sep 3, 2009
14
0
My apologies. I skimmed over the last portion of the thread because it was mostly the first few posts that seemed relevant to me.

My problem may be slightly different. I can no longer connect to the Samba shares, much less write anything to them now that I have updated to 10.6.3. The shares seem to be fine, as others can still connect with Win7 (at least—I haven't talked with anyone else on campus).
Start by checking out if unix extensions is off in Samba (is ON by default in samba starting with a release I d not remember). If not, disable it unless you _really_ need it on the samba server. If you don't know, you probably do not need it and can disable it in samba.

Check if you still have problems after that... I haven't seen if any problems still persists with MAC after disabling this in the server. Well... not yet....

/Per-Olov
 

pos

macrumors newbie
Sep 3, 2009
14
0
Quote:
Originally Posted by drbob49
This is the result of a ls -al command in the terminal. Of the two files sample.doc cannot be copied from the mac to the samba share whereas test.pdf can.

drwxr-xr-x 4 bob bob 136 8 Apr 20:28 .
drwx------ 22 bob bob 748 8 Apr 20:26 ..
-rw-r--r--@ 1 bob bob 75776 8 Apr 20:28 sample.doc
-rw-r--r-- 1 bob bob 1789356 8 Apr 20:27 test.pdf

Most files in my home directory have the @ attribute (whatever it is) - with the exception of pdf, zip, rar and bz2 files. As a workaround, if I zip up a collection of files they can then be shared - not very elegant though!

Bob

##On my mac...
sjoholmp:~ sjoholmp$ ls -al /Users/sjoholmp/VMWARE*
-rwxr-xr-- 1 sjoholmp staff 1003 10 Nov 18:01 /Users/sjoholmp/VMWARE-root.sh
-rwxr-xr--@ 1 sjoholmp staff 1012 10 Nov 17:51 /Users/sjoholmp/VMWARE.sh
sjoholmp:~ sjoholmp$


## On my Samba target server (after drag´n drop in MAC to the samba share)
rver:~ # ls -al /home/sjoholmp/VMWARE.sh
-rwxr--r-- 1 sjoholmp sjoholmp 1012 Nov 10 17:51 /home/sjoholmp/VMWARE.sh
server:~ #


No problem....

/Per-Olov

The "@" on the file means the file has extended attributes.

I have done more tests... I can see your problems if "unix extensions is ON in samba (default). Then the same problems applies to me as well (with the file copy above). The problems is gone if unix extensions is turned OFF.

/Per-Olov
 

drbob49

macrumors newbie
Apr 7, 2010
3
0
Quote:
Originally Posted by drbob49
This is the result of a ls -al command in the terminal. Of the two files sample.doc cannot be copied from the mac to the samba share whereas test.pdf can.

drwxr-xr-x 4 bob bob 136 8 Apr 20:28 .
drwx------ 22 bob bob 748 8 Apr 20:26 ..
-rw-r--r--@ 1 bob bob 75776 8 Apr 20:28 sample.doc
-rw-r--r-- 1 bob bob 1789356 8 Apr 20:27 test.pdf

Most files in my home directory have the @ attribute (whatever it is) - with the exception of pdf, zip, rar and bz2 files. As a workaround, if I zip up a collection of files they can then be shared - not very elegant though!

Bob




The "@" on the file means the file has extended attributes.

I have done more tests... I can see your problems if "unix extensions is ON in samba (default). Then the same problems applies to me as well (with the file copy above). The problems is gone if unix extensions is turned OFF.

/Per-Olov
You are right - when i tried the unix extensions off earlier, I'd amended smb.conf in the section that related to the specific share. I moved the "unix extensions = no" entry into the [global] section of smb.conf, restarted samba and everything works well. Phew and thanks!

Of course, since the server is mine to control and setup, this fix is OK - not sure if campus wide servers would be amenable to such a change.

VMT

Bob