after 3.0 update the ipod on iphone wont work

Discussion in 'iPhone Tips, Help and Troubleshooting' started by adamfedoruk, Mar 20, 2009.

  1. adamfedoruk macrumors newbie

    Joined:
    Mar 20, 2009
    #1
    after i updated to 3.0 and everything, everything works except for the fact that i can not open the ipod. it just crashes
    i have iphone 3g
    turned off and turned back on phone
    re-installed 3.0 beta.
    still wont work
    anyone have this problem?
     
  2. macfan881 macrumors 68020

    Joined:
    Feb 22, 2006
    #2
    congradulations your iphone is bricked :D lemme guess you did not sign up for the 99 dev fee did you if not you now have a 200 paperweight :)
     
  3. adamfedoruk thread starter macrumors newbie

    Joined:
    Mar 20, 2009
    #3
    youre an idiot, i am a iphone dev.
    i said everything worked, sans the ipod.app
    read my post before replying
     
  4. macfan881 macrumors 68020

    Joined:
    Feb 22, 2006
    #4
    um excuse me before you start being rude :mad: you could have stated your a dev other people have installed the beta not realizing you have to register so next time be a lil more specific.:rolleyes:
     
  5. adamfedoruk thread starter macrumors newbie

    Joined:
    Mar 20, 2009
    #5
    or maybe you could not assume i dont know what i am doing
     
  6. CaryMacGuy macrumors 6502a

    CaryMacGuy

    Joined:
    Oct 2, 2006
    Location:
    Morrisville, NC
    #6
    I did get a 3rd party software 3.0 on my iPod Touch and it seems pretty stable. The only thing that seems to be not functioning is Maps and Youtube. I am probably going back to the 2.2.1 software since I just wanted to see what the fuss was about. I am really excited about this release, however!
     
  7. wil49 macrumors member

    Joined:
    Mar 18, 2009
    Location:
    Chester, UK
    #7
    Have you tried something as simple as a reboot? If not you mite need to do the update again but with a clean install, this is just from what I have been reading not my experience.
     
  8. desonnaville macrumors newbie

    Joined:
    Mar 21, 2009
    #8
    i have the same problem, i dont know what to do, because i've also reinstalled the iphone but the problem isnt gone
     
  9. mkvowner macrumors newbie

    Joined:
    Mar 21, 2009
    #9
    Per the NDA, you can't post on forums and talk about 3.0. Put your phone in restore mode, restore, and try the iPod app again.
     
  10. stevepeck macrumors member

    Joined:
    Jul 14, 2008
    Location:
    HULL-Yorkshire-UK
    #10
    More Bricks

    Me thinks there's gonna be lots of Bricked lphones out there, if you cannot wait for a few more weeks, then tough ****.
     
  11. KingHuds macrumors 6502

    Joined:
    Aug 2, 2008
    #11
    Its not bricked...if people would just learn to read. just the iPod app is having troubles.
     
  12. Scavenger macrumors newbie

    Joined:
    Mar 13, 2006
    #12
    I had the same issue, although the ipod app was working initially - then stopped working.

    It crashed whenever you attempt to launch the app - this seemed to have occured after I downloaded a podcast through the Wireless iTunes store.

    I removed the podcasts from my ipod and the app will now launch successfully.

    Hope this helps with your phone as well - will submit feedback to apple in regards to this aspect of the 3.0 Beta.
     
  13. lsta macrumors newbie

    Joined:
    Mar 22, 2009
    #13
    I've the same problem with 3.0 on 3g.

    Unfortunately, my iPod.app crashing wasn't as easily solved, though I agree it may have something to do with the improvements to Podcast playback. I just unchecked the Podcasts sync checkbox, and it didn't help, sigh.

    If it's podcast-related, I'll try to fix the music playback, perhaps by completely reinstalling the 3.0 beta ipfw, then sticking to using RssPlayer.app for podcasts. :)

    I just turned off music sync in iTunes, in the hopes that I can at least restore the iPod.app screen saying there's no content available, without fully resetting the iPhone. ( Wow sync is fast without the Music to slow it down :D )

    And yes, now I've an iPod.app working again! It loaded on "Songs" where I last was, and oddly enough, it still has two copies of "Consolation Prize" by Julie Doiron, the free singe of the week that I downloaded once on my PC and once on the iPhone, in the hopes that clicking the "Purchased" button in iTunes.app on the phone would load iPod.app without crashing. (It didn't.)

    Oddly enough, one of the two Consolation Prize songs is missing album art. Both are playable, however.

    And there's no way to delete the songs, as you need iTunes to do that, and iTunes thinks there's no music on the device. Strange. Oh, actually iTunes sees just one of the two Consolation Prize songs, the one with album art. It's greyed out however, as Manually manage isn't checked.

    Now, with Music still sync-disabled, I've re-enabled Podcast-sync to see if that works. (Copying over 10 GB of music takes longer.) I really do like how Podcasts now function, though I can't describe much here for fear of Apple's legal team. Suffice to say that if it works this summer, I see little need to keep RssPlayer, except when I want to download more than 10mb of podcast and not stream it.

    And yes, Podcast sync finished, and iPod.app still launches. So it seems that if iPod.app crashes under the current 3.0 fw, you should be able to fix it by unchecking the Podcast sync, or the Music sync. If neither of those works, maybe try unchecking the Video sync also, though I didn't have to.

    Hope this helps any other devs working with 3.0 on their everyday phone,


    Louis.
     
  14. frankyp macrumors newbie

    Joined:
    Mar 24, 2009
    #14
    I'm having the exact same problem

    I downloaded a podcast this morning, and now ipod.app crashes every time. Furthermore, the desktop search function sees none of my songs. On the Settings->About screen, the phone now thinks I have 0 songs, but it's also reporting that I only have 4.2GB available, so the songs are clearly still taking up space.

    I supposed I'll just have to do a full wipe and restore from iTunes.

    Apple really needs to disable the iTunes store app for 3.0 phones if it's going to break things this much.
     
  15. DPA macrumors 65816

    DPA

    #15
    You are a developer, correct. This is the reason Apple has only released iPhoneOS v3.0 as a Beta. It still has problems and the iTunes Mobile Store is clearly one of them.

    I think a full restore will be necessary, hopefully you kept backup files from 2.2.1.

    David
     
  16. lsta macrumors newbie

    Joined:
    Mar 22, 2009
    #16
    An update on my last post

    Just a quick update on my last post ...

    I've since managed to listen to and sync all my podcasts, but no matter what I do, I can't sync my purchased songs / music. To fix this, I have to sync without podcasts and without music, then I can sync back the podcasts.

    At some point, I think I'll try a full restore of the ipfw. I hope it was the iTunes app that somehow caused the crashing in the first place, as if it was some file in my music library, I've no choice but to wait for a new firmware release.

    Still, at least I'm getting a lot of mileage from last.fm, FlyCast and other online radio apps.
     
  17. igaenssley macrumors newbie

    Joined:
    Apr 2, 2009
    #17
    Hate to be a butt, but it's really not a good idea to be discussing the 3.0 beta on a public forum, especially if your username is easily identifiable. Apple unfortunately get's really snippy about that kind of thing.

    I hope your problem is fixed, but for your developer license's sake, you may want to move this off a public area.
     
  18. lsta macrumors newbie

    Joined:
    Mar 22, 2009
    #18
    The latest beta has fixed the problem for me. But even so, I've no way to delete this. If an admin or moderator can, please do so.

    Thanks.
     

Share This Page