After cloning the HD permissions problem? Help please! 500GB in MBP rocks!

Discussion in 'macOS' started by DaveTheGrey, Aug 18, 2008.

  1. DaveTheGrey macrumors 6502a

    DaveTheGrey

    Joined:
    Dec 28, 2003
    #1
    Hi everybody!

    The good part :) :

    I bought the new Samsung Spinpoint M6S 500GB HM500LI to replace my WD Scorpio 250GB.
    What I did:
    1. Bought the HM500LI in an external USB enclosure.
    2. Made one partition with a GUID Table
    3. Formated it Mac OS X Journaled
    4. Cloned my internal drive with Carbon Copy Cloner
    5. Swaped the drives.
    -> :D everything works perfectly. The Samsung is much faster than the WD and it is very silent. Now I've plenty space for my fotos!

    The bad part (HELP) :( :

    I wanted to do my dad a favour and gave him my 250GB WD to replace his 160GB original Apple drive. He's got exact the same SR MBP like me.
    So I did steps 2 to 5 and everything seemed ok but it isn't.

    Symptoms:
    M$ Word won't start anymore (tells me there is not enough diskspace)
    Photoshop won't start anymore (tells me it can't access the volume)
    Preview won't open any files.
    Other apps are just running fine.

    So I think it might be a permissions problem. I could reinstall all apps, I could reinstall OS X and migrate from the time machine backup, but I don't know if this would help and so I wanted to ask first if there is better/faster solution...

    What I've already tried:
    - repairing disk permission from within os x
    - repairing disk permission from the leopard dvd
    - repairing the hd (diskutility)
    - tried a preview.app from another mac

    I googled for the problem and I found a thread with the same topic. The guy even reinstalled Photoshop with no luck. No other solutions where mentioned.

    I don't have the files of the original hd anymore, because I erased it...
    I don't have the the time machine backup from the original hd anymore, because I did a new time machine backup after swapping the drives.

    Any help would be very appreciated!
    Sorry for my english.

    Dave

    UPDATE

    I tried to install Onyx but it refuses to work, told me the Admin password isn't right.
    It told me to repair permissions but it didn't help.

    Then I created a new Admin User and what can I say, all the apps are working under this new test account...
    So it seems that the user account has a dent.

    I booted from the Leopard DVD and tried to resest the Admin Password (to the same as it was before).
    No luck....

    UPDATE2

    First, thanks for your time and help!
    I fixed the problem the hard way...
    It seems as if there is no "Fix corrupt user account" button in OS X or any tool, as far as I know.

    So here comes what I did:

    1. Cloned the affected drive on an external USB drive with CCC.
    2. Made a Backup with YourBackup and copied it to /users/for all users/
    3. made a new user with admin privileges called "test"
    4. loged out, loged in as test
    5. deleted old user account
    6. made new admin user account with the same name and the same pass as the old one.
    7. logged out, logged in as the new user
    8. Restored the Backup with YourBackup (I love this ap!!!)
    Adress Book, FireFox, Fonts, iCal, iChat, Keychain, Mail, Prefernce Panes, Quicktime, Safari, ScreenSavers, Stickies, Widgets everything was instantly there.
    Except iCal wich needed the /users/username/library/calendars folder to copy from the USB drive to the new user's library in order to work.
    9. Then I copied all folders from the USB drive under /user/username/library/application support/ which seemed to be needed, depending on the aps my dad was still using.
    10. Then I copied some folders from user/username/library/ like Phones iTunes and Syncservices (don't know if it was needed but his iPhone synced well after that).
    11. Copied alle the user data, like photos, music and so on

    Perhaps this helps someone in the future.

    Bye

    Dave
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    As I read your post, the solution that was forming in my mind was to restore from the old files. Until I got to the last couple of sentences. At this point, I would have to consider rebuilding everything. This would involve backing up all his user data, then doing an erase and install of the OS, then restore his user data. No TM backup restore. No quick fix. First install the OS and make sure it's working, including Preview. Then install M$ Word and Photoshop. You might want to call Adobe in case there are any activation issues. Once those are working, you can restore his files only from the manual backup of everything in his Documents folder.

    Sorry, while this is painful, hopefully it teaches you to never never never destroy a backup until absolutely everything is tested on the new machine. I've STILL got my backup when I went from SR to Penryn 6 months ago. I've STILL got my backup when I went from XP to OS X. There's just no substitute for holding onto backups. Next time, point TM to a different volume and don't let it erase the old backup until you know you no longer need it. In one of the online communities I visit, there is a wise sig that says...

    Experience is what you were getting when you thought you were getting something else.
     
  3. DaveTheGrey thread starter macrumors 6502a

    DaveTheGrey

    Joined:
    Dec 28, 2003
    #3
    It isn't THAT painful :D
    I did this before and it was ok, but if there would be a better way I'd like to go it.
    Thanks for your time!

    P.S. I updated my post.
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    You've definitely got a corrupt user account. Fixing it is not going to be easy, though. One way to find out where the problem lies is to transfer files from the bad account to the good one, and see if the good account goes bad. For example, if, after copying over all the preferences from the bad account, the good account exhibits the same issues, you now know the culprit is a corrupted preference file.
     
  5. DaveTheGrey thread starter macrumors 6502a

    DaveTheGrey

    Joined:
    Dec 28, 2003
    #5
    Thanks for your time! :)


    P.S. I updated my post


    Dave
     
  6. poppe macrumors 68020

    poppe

    Joined:
    Apr 29, 2006
    Location:
    Woodland Hills
    #6
    I was curious if the 500 gb was working okay? I am so tempted to do this.

    -Is the hard drive effecting the battery life.
    -Is the hard drive running at 5200 rpm or is it actually running slower?
    = I ask because I had a friend who tells me the MBP is not powerful enough to power the hard drive.
     
  7. Objectivist-C macrumors 6502

    Joined:
    Jul 1, 2006
    #7
    Judging by the spec sheet, it doesn't appear to be a battery-guzzling monster. It uses less power under load than the stock HD in my iBook.
     
  8. gusious macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
    #8
    Congrats for solving the problem!! But why didn't you just reinstall OSX from scratch? Rather than moving files?
     
  9. mckyvlle macrumors 6502a

    Joined:
    Nov 21, 2007
    Location:
    London, UK
    #9
    I had similar experience when changing to my WD 320GB hard disk. Apps would not launch from the cloned drive. I got everything working by repairing permissions, clearing the system and user caches and update prebindings.
     
  10. DaveTheGrey thread starter macrumors 6502a

    DaveTheGrey

    Joined:
    Dec 28, 2003
    #10
    I can tell you it runs perfectly, loading times are faster than with my 5200rpm WD Scorpio and it's much quieter. I really love my Spinpoint! :D
     
  11. DaveTheGrey thread starter macrumors 6502a

    DaveTheGrey

    Joined:
    Dec 28, 2003
    #11
    Lucky you... I wish that would have helped... I didn't update the prebindings though. Wonder if that would have made it.
     
  12. DaveTheGrey thread starter macrumors 6502a

    DaveTheGrey

    Joined:
    Dec 28, 2003
    #12
    After searching the net for a solution I found an article where someone had the same problem and a os x reinstall didn't help him...
     
  13. gusious macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
    #13
    Oh ok!! Congrats anyway!! That was a bit hard to accomplish!:)
     
  14. poppe macrumors 68020

    poppe

    Joined:
    Apr 29, 2006
    Location:
    Woodland Hills
    #14
    Do we know what the power consumption is on a stock MBP?

    That's great to hear. I'm pretty sure I'll go with this, but I just want to make sure I have everything covered first.
     

Share This Page