After force-quitting an application won't restart

Discussion in 'macOS' started by franz1999, Apr 23, 2009.

  1. franz1999 macrumors member

    Joined:
    Feb 10, 2008
    #1
    I have been searching all over the Internet and can't find a solution to this problem. Sometime when some application hangs I try to force quit it and the process completely disappears from the Activity Monitor, but the little white marker under the icon on the dock remains and there is no way to restart the application. Does any one know of an easy way out without having the restart the machine?
    I have a 2008 MBP with Leopard 100% up-to-date on the machine, if this info can help...
    Thanks,
    Francesco

    I tried restarting the application directly from the Application folder instead of double clicking on the dock, and I got "An unexpected error occurred (error code -600)" -- according to Apple, error code -600 means: procNotFound - No eligible process with specified process serial number
     
  2. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #2
    Not sure if it will work, but you can open a terminal, see if the process still shows up with a ps command, then kill it if it does.
     
  3. franz1999 thread starter macrumors member

    Joined:
    Feb 10, 2008
    #3
    Thanks for your reply.
    No, never tried PS and I am not so familiar with it. I did try to use TOP from terminal and I was never able to see the process... it's as if disappeared correctly but something was left lingering around in the system that prevents OS X from re-opening the same application again.

    It has happened often with Photoshop, sometimes with Firefox, recently with some other app, tonight with Thunderbird. The laptop is completely up-to-date, all patches installed.
     
  4. Dimwhit macrumors 68000

    Dimwhit

    Joined:
    Apr 10, 2007
    #4
    When this happens to me, I option-right-click the icon in the dock and select Force Quit (which is usually available as an option when this happens). Sometimes I have to do that a number of times, but it eventually releases the app.
     
  5. franz1999 thread starter macrumors member

    Joined:
    Feb 10, 2008
    #5
    Someone else who has the same issue! I tried that 2-3 times but never was able to "release" the app. How often do you have this problem, if you don't mind me asking? Have you narrowed it down to some cause? Maybe some apps are more inclined to become ghosts like that? When you say "a number of times" do you mean like 10-15 times? Have you always been able to release the app are did you have to close the system?
    Sorry for the many questions :)
     
  6. Dimwhit macrumors 68000

    Dimwhit

    Joined:
    Apr 10, 2007
    #6
    It doesn't happen all the time. Occasionally with Firefox. Sometimes with other miscellaneous apps. I haven't pinpointed a cause or specific apps, unfortunately. It can take me a dozen or two times to finally get it to quit. Once in a while, I have to restart the computer to fix it, but that's rare.

    I suspect the cause involve conflict with third-party apps. I have a magicJack, and I think that app has caused this a few times.

    Sorry, not many answers. But I do feel your pain! :) (All that said, it hasn't happened enough to me for it to be a major pain.)
     

Share This Page