After Jailbreak, Can Receive, Can't Initiate FaceTime Calls

epicurean

macrumors newbie
Original poster
Jun 22, 2010
6
0
I had just used FaceTime this morning, before jailbreaking. After jailbreaking, upon hearing that the MMS and FaceTime issues had been resolved, I used jailbreakme.com, but could not initiate FaceTime calls, I can only receive them. I've tried restoring as new phone, jailbreaking, complete upgrade on Cydia, reset network settings and reboot, but still can not initiate FaceTime calls. When the iPhone on the receiving end accepts the FaceTime call, I get one of two errors: FaceTime Unavailable, or Caller Name is not available at the moment.

Any advice?

Update: Seems that my phone is fine, but it is her phone that cannot receive FaceTime calls. When she answers, her phone hangs at "connecting" while the calling phone says user "is not available at this time". Can't seem to find anyone else having this problem.
 

romeo.xk

macrumors 6502a
Mar 26, 2009
547
22
Restore and do it again, If you did your jailbrake too eraly that was one of the problems, I bet you also lost mms...
 
Comment

epicurean

macrumors newbie
Original poster
Jun 22, 2010
6
0
I've restored as a new phone at least 3-4 times throughout the day, latest being about an hour ago. I never experienced the MMS issue and I was, and still am, able to receive FaceTime calls, but these issues come up only when I try to initiate.
 
Comment

deleonju

macrumors newbie
Feb 21, 2008
8
0
are you still having this issue? I don't think it's your phone. it's your wife's iphone. I'm having the same problem with a friend's iphone. he can call out fine, but when anyone calls him for facetime, the call fails..
 
Comment

epicurean

macrumors newbie
Original poster
Jun 22, 2010
6
0
are you still having this issue? I don't think it's your phone. it's your wife's iphone. I'm having the same problem with a friend's iphone. he can call out fine, but when anyone calls him for facetime, the call fails..
Yes, I realized yesterday that we are still having the issue, and it does, in fact, seem to be a problem with my wife's phone. It seems as though she can't receive FaceTime calls, it just hangs at "connecting" after she answers, and for the initiating phone, it says that the user is "busy at this time", or something along those lines. Did you find any other information on this?
 
Comment

coolpal

macrumors member
Oct 27, 2006
65
0
I have the same problem. My phone is jailbroken and can recieve facetime calls (even on 3g) but can't place a call to my wife's un-jailbroken phone (even on wifi). How did you guys conclude that it's not your phone, but the other phone which has this problem?

Unfortunately for me, I don't have other iPhone 4s to test this, but I think it's a problem with mine, since we were able to place facetime calls both ways before I jailbroke, and my wife's phone is still the same way as before.. so it must be mine :(

Please post if you found a solution.

pal :)
 
Comment

deleonju

macrumors newbie
Feb 21, 2008
8
0
The only way we were able to fix it was by restoring the phone and setting up as new. The reason being that every time you restore from backup the problem returns. Jailbroken or not.

My theory is that when you jailbroke your iPhone and installed 3G unrestrictor, then placed a face time call to your wife. For some reason, it ends up corrupting some file on the receiving iPhone. Afterwards the phone stops receiving face time calls. It's just a theory though. I don't know which file it is. I tested a couple of files, plists, etc., but nothing worked. So we ended up just restoring as new. So far so good.

Hope this helps..

JC
 
Comment

coolpal

macrumors member
Oct 27, 2006
65
0
thanks for responding... so did you have to restore the other phone or your phone, or both?
I restored mine, and even before setting up the device, I tried facetime and it still didn't work.
 
Comment

GunBlazerX

macrumors member
Aug 3, 2010
51
0
Umm I'm pretty sure all you have to do is go to settings -> phone -> facetime on

The jailbreak sets this to off by default
 
Comment

bw1128

macrumors 6502a
Jun 29, 2010
631
0
I had just used FaceTime this morning, before jailbreaking. After jailbreaking, upon hearing that the MMS and FaceTime issues had been resolved, I used jailbreakme.com, but could not initiate FaceTime calls, I can only receive them. I've tried restoring as new phone, jailbreaking, complete upgrade on Cydia, reset network settings and reboot, but still can not initiate FaceTime calls. When the iPhone on the receiving end accepts the FaceTime call, I get one of two errors: FaceTime Unavailable, or Caller Name is not available at the moment.

Any advice?

Update: Seems that my phone is fine, but it is her phone that cannot receive FaceTime calls. When she answers, her phone hangs at "connecting" while the calling phone says user "is not available at this time". Can't seem to find anyone else having this problem.
this happened to me and i talked to apple and at&t for several hours trying to fix it. i ended up having to retore as new and that fixed my problem. cross my fingers it stays fixed!
 
Comment

ashy7

macrumors newbie
Aug 9, 2010
19
0
I am having the same issue. When I ring my friend it works fine, but when they ring me it says connecting on mine, and user busy on theirs.

Cydia was updated after the JB and it is switched on, as I can call them!
 
Comment

deleonju

macrumors newbie
Feb 21, 2008
8
0
thanks for responding... so did you have to restore the other phone or your phone, or both?
I restored mine, and even before setting up the device, I tried facetime and it still didn't work.
You have to restore and set up as new the phone that can't receive. The unjailbroken one in your case.

Updating cydia doesn't fix it. The problem can happen on a phone that's not jail broken. Although I suspect one of the phones needs to be in order for the problem to occur.
 
Comment

deleonju

macrumors newbie
Feb 21, 2008
8
0
Anybody still having this problem? I think I found a way to fix this without doing a restore as new. you would need to be jailbroken and delete the file: com.apple.conference.history.plist in the preference folder of the user mobile. I'm pretty sure that's going to fix it. but I can't test it anymore..

login via ssh and:

rm /var/mobile/preferences/com.apple.conference.history.plist

hopefully this will help someone.. ;-)
 
Comment

T-Will

macrumors 65816
Sep 8, 2008
1,003
387
You might try this?

http://www.iphonedownloadblog.com/2010/08/06/fix-facetime-failed-xxx-is-not-available-for-facetime/

Fix: FaceTime Failed – xxx is Not Available For FaceTime
by Sebastien

Today I want to post about an issue I recently had when trying to FaceTime with Tina. Everytime I tried to initiate a FaceTime call, I would get an error message saying “FaceTime Failed – Tina is not available for FaceTime“. What was strange with this issue is that she could initiate the FaceTime call and reach me, but I couldn’t.

So really I thought the problem was from me since I was the one not being able to reach her. This drove me nuts for days. I even went as far as restoring my iPhone, thinking it would fix the issue. It didn’t. The solution was in fact much simpler. Ironically, the issue didn’t even come from my iPhone, but from hers.

I found the fix somewhere deep inside Apple’s support pages. Apparently the problem arises if you ported an old number to your iPhone 4, or if you recently changed your number, which was the case for Tina’s phone.

According to Apple, some of the symptoms are:

When you are calling someone on FaceTime, the number on their screen is not your number.
People are unable to initiate a FaceTime call with you.
After installing a new carrier settings update, FaceTime does not activate.

The fix is really simple:

In Settings > Phone, turn FaceTime OFF and turn it back ON again
Go to Settings > General > Reset > Reset all settings
Done

Immediately after performing this on Tina’s phone I was able to initiate a FaceTime call with her.

Hopefully this will help other people stuck on this issue.

"Fix: FaceTime Failed – xxx is Not Available For FaceTime" is an article by the iPhone Download Blog sponsored by the iPhone Store. Feel free to leave a comment or discuss this topic in the forum. For the latest iPhone info, don't forget to follow me on Twitter.
 
Comment

LoLife

macrumors regular
Jun 1, 2010
223
11
Reno, NV
Anybody still having this problem? I think I found a way to fix this without doing a restore as new. you would need to be jailbroken and delete the file: com.apple.conference.history.plist in the preference folder of the user mobile. I'm pretty sure that's going to fix it. but I can't test it anymore..

login via ssh and:

rm /var/mobile/preferences/com.apple.conference.history.plist

hopefully this will help someone.. ;-)

Thanks for the advice, althought I tried this and it has not seemed to worked. I am, and have been, getting a "facetime failed" everytime either call coming in or im calling out. I tried deleting that filed didn't seem to work. Waiting for best buy to get some snow lepoard (other computer got stolen bastards) so I can update my old mac to do a full restore. Hate not having facetime, worked fine for probably 3-5 days after jailbreak even worked on 3g but now it won't work at all. I have tried restoring settings, turning facetime button on and off and turning the phone on and off and just tried ^^ this and it didn't work. Anyone else have any advice I would be more then willing to try it out. Thanks guys :confused:
 
Comment

deleonju

macrumors newbie
Feb 21, 2008
8
0
Thanks for the advice, althought I tried this and it has not seemed to worked. I am, and have been, getting a "facetime failed" everytime either call coming in or im calling out. I tried deleting that filed didn't seem to work. Waiting for best buy to get some snow lepoard (other computer got stolen bastards) so I can update my old mac to do a full restore. Hate not having facetime, worked fine for probably 3-5 days after jailbreak even worked on 3g but now it won't work at all. I have tried restoring settings, turning facetime button on and off and turning the phone on and off and just tried ^^ this and it didn't work. Anyone else have any advice I would be more then willing to try it out. Thanks guys :confused:
try deleting the com.apple.conference.plist and com.apple.conference.history.plist.

that's basically what the reset all settings would do for facetime.. I'd think..

;-)
 
Comment

arkon

macrumors member
Aug 17, 2010
68
0
That worked for me!

You might try this?

http://www.iphonedownloadblog.com/2010/08/06/fix-facetime-failed-xxx-is-not-available-for-facetime/

Fix: FaceTime Failed – xxx is Not Available For FaceTime
by Sebastien

Today I want to post about an issue I recently had when trying to FaceTime with Tina. Everytime I tried to initiate a FaceTime call, I would get an error message saying “FaceTime Failed – Tina is not available for FaceTime“. What was strange with this issue is that she could initiate the FaceTime call and reach me, but I couldn’t.

So really I thought the problem was from me since I was the one not being able to reach her. This drove me nuts for days. I even went as far as restoring my iPhone, thinking it would fix the issue. It didn’t. The solution was in fact much simpler. Ironically, the issue didn’t even come from my iPhone, but from hers.

I found the fix somewhere deep inside Apple’s support pages. Apparently the problem arises if you ported an old number to your iPhone 4, or if you recently changed your number, which was the case for Tina’s phone.

According to Apple, some of the symptoms are:

When you are calling someone on FaceTime, the number on their screen is not your number.
People are unable to initiate a FaceTime call with you.
After installing a new carrier settings update, FaceTime does not activate.

The fix is really simple:

In Settings > Phone, turn FaceTime OFF and turn it back ON again
Go to Settings > General > Reset > Reset all settings
Done

Immediately after performing this on Tina’s phone I was able to initiate a FaceTime call with her.

Hopefully this will help other people stuck on this issue.

"Fix: FaceTime Failed – xxx is Not Available For FaceTime" is an article by the iPhone Download Blog sponsored by the iPhone Store. Feel free to leave a comment or discuss this topic in the forum. For the latest iPhone info, don't forget to follow me on Twitter.
This fixed my problem with
"People are unable to initiate a FaceTime call with you."

And it feels much faster, the animations and faster starts of the applications.
 
Comment

coolpal

macrumors member
Oct 27, 2006
65
0
Thanks T-Will.... I did the reset all settings on my wife's phone (non jailbroken) and all is good now...

pal :)
 
Comment

Alex Mellor

macrumors newbie
May 25, 2020
1
0
I have found a fix for this if anyone would like to know. My phone is jailbroken but in the jailbroken state i cant use face time. My solutuion is to install aa tweak called "Power Selector" In this app all you will need to do is press safe mode, all your tweeks will temperaoly be suspend and your device will respring. Facetime works for me in this mode and as soon as you hang up on faectime go back into the app press safe mode again then press reset and your device will respring back into jailbroken state. This is the easiest solution for me and very conveninent aswell as it doesnt make your device do a full reboot only respring.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.